User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: 1.9 CDTI Turbo Problems??

  1. #1
    Regular Member CDTI120SXI's Avatar
    Join Date
    Mar 2011
    Location
    Wrexham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default 1.9 CDTI Turbo Problems??

    Hi, I'm looking for some help on my 05 1.9 CDTI 120.

    If i cruise a long at around 2000RPM and keep a constant speed then go to put my foot down the car will sort of jerk a bit like its loosing power and before picking up and accelerating. The best way i can describe it is the turbo cuts out and comes back in.

    Any ideas? it's driving me crazy, could it be my driving?


    Thanks

  2. #2
    Full Member GazVXLINE170's Avatar
    Join Date
    Jun 2007
    Location
    Scotland
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default

    In all likely hood the EGR valve is the culprit or the vacuum hoses. If these are fine or you have replaced them then I'd say the turbo vanes may be jamming, but don't go aiming for the expensive cause first, eliminate the simple and cheapest first.

    Gazza4
    Insignia VX-Line Nav CDTI 170.

  3. #3
    Regular Member Ginge7289's Avatar
    Join Date
    Jan 2011
    Location
    Woodbridge
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    2000RPM is high, turbo kicks in around 1800.

  4. #4
    Regular Member CDTI120SXI's Avatar
    Join Date
    Mar 2011
    Location
    Wrexham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Boost pipes look ok so i guess ill replace the EGR valve.

    P.S it happens when the engine is warm.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. turbo problems
    By bobthebarber in forum Engine & Drivetrain
    Replies: 1
    Last Post: 22nd January 2012, 20:35
  2. Turbo problems
    By jonbav in forum Engine & Drivetrain
    Replies: 12
    Last Post: 31st March 2011, 15:44
  3. Turbo problems 2.0 Dti
    By brotherkennyh in forum Engine & Drivetrain
    Replies: 6
    Last Post: 27th August 2010, 12:19
  4. cdti 120 turbo problems (i think)
    By robhullfury in forum Engine & Drivetrain
    Replies: 2
    Last Post: 27th July 2008, 13:49
  5. Turbo problems?
    By FRANKA in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 2nd October 2006, 15:12

Visitors found this page by searching for:

vectra c turbo problems 1.9

vectra 1.9 cdti turbo problems

vectra c 1.9 cdti turbo problems

vectra 1.9cdti turbo issues

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •