User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: incorrect range readout from trip computer

  1. #1
    Regular Member
    Join Date
    Oct 2010
    Location
    glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default incorrect range readout from trip computer

    Hello guys,

    Would anyone know why my trip computer is showing that I have only zero miles of fuel till the tank is empty and its showing that the miles covered is zero also. All this and my tank is 1/4 full.

    Any help would be great thanks!

    Mo

  2. #2
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Is there any thing else missing, such as temperature, ignition logic or lighting control.

    Process of elimination..

    No temp read-out = faulty Low CAN wire to the BCM (Body Control Module)

    Dodgey fuel readings and possibly no Ice Crystal warning, no ignition logic, no lighting control = faulty Low CAN connection to CIM (Collumn integrated module) from the instrument cluster or BCM
    But you would get outside temperature.

    Fuel Computer only = faulty CAN connection from the UEC (Underhood electrical centre), or ABS (Anti Lock Brake System) module.

    Do the instruments register a road speed etc... - If the speedo is fine, then this rules out the ABS unit...

    I am thinking that you need a diagnostic read-out, to see which modules are not communicating.

    Finally... The display may be faulty... Problem with the internal programming. (Firmware).

    The UEC is nagging at me... if it was the CIM, then the values would come up as "F"...

    Like I said, see if anyone local to you have Tech 2, Op-Com or Vaux-Com...

  3. #3
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If you fill up does it change?
    Now I need a turbo to keep up!

  4. #4
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    I thought that at first, but for the mileage covered to be zero...
    that is a CAN fault..
    Lack of comms somewhere

  5. #5
    Regular Member Ginge7289's Avatar
    Join Date
    Jan 2011
    Location
    Woodbridge
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I know it will not help. But when the damn thing works, it lies anyway.

  6. #6
    Regular Member kenp's Avatar
    Join Date
    Feb 2008
    Location
    Kr. Hyllinge, Denmark
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C


    Engine : 2.2 Direct

    Year : 2004

    Default

    Wrong code index?

  7. #7
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    If the values are out by a fair margin, then I would agree with the code index issue,

    but if the Fuel Computer readings are Zero, then the Display is not getting any fuel and speed pulse information..

  8. #8
    Regular Member kenp's Avatar
    Join Date
    Feb 2008
    Location
    Kr. Hyllinge, Denmark
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C


    Engine : 2.2 Direct

    Year : 2004

    Default

    ahhh didnt notice that bit yes could just be a broken/loose wire to the BCM..

  9. #9
    Full Member Robsey's Avatar
    Join Date
    Dec 2006
    Location
    North East Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Energy

    Engine : Z19DTH

    Year : 2005

    Mileage : 131,000

    Default

    Aye, but which one..

    Info is normally

    ABS Module to CIM
    UEC via ECM to CIM
    CIM to Instrument Panel (pin 5)
    Instrument Panel (pin 6) to BCM (pin 41)
    BCM (Pin 40) to Display (pin 28)

    Only plausible way around this, is that the trip computer (BC) has been reset (both BC1 and BC2), and that you have put less than 10 litres of fuel in...
    Last edited by Robsey; 15th April 2011 at 21:56.

  10. #10
    Regular Member kenp's Avatar
    Join Date
    Feb 2008
    Location
    Kr. Hyllinge, Denmark
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C


    Engine : 2.2 Direct

    Year : 2004

    Default

    Would actually think the problem is with the ABS module.. the plug there.. have heard about other where it helped clean out that plug..

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trip computer Range accuracy
    By Casey in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 16th February 2012, 18:20
  2. Help with Range feature on trip Computer
    By BRYBURN in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 19th September 2009, 19:06
  3. mpg range trip computer how do you use it...
    By vec3.2 in forum Bodywork & Interior
    Replies: 19
    Last Post: 15th March 2009, 23:40
  4. Trip Computer live MPG readout.
    By pete63 in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 17th April 2008, 21:36
  5. Range on Trip computer
    By cdms811 in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 29th November 2007, 11:11

Visitors found this page by searching for:

https:www.vectra-c.comforumshowthread.php135321-incorrect-range-readout-from-trip-computer

vectra c trip computer not correct

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •