User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Random Power Steering Failure

  1. #1
    Regular Member
    Join Date
    Mar 2010
    Location
    Lincs
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Random Power Steering Failure

    Hi all.

    Filled up with fuel, started car, drove off and, have i 2 flat tyres? Power steering lamp on on dash. Pulled in and turned engine off. Restarted and fault cleared, been ok for 300-400 miles.

    Is this just a totally random fault or is there something i need to be checking out please?

    Thank you.

    Paul.

  2. #2
    Regular Member
    Join Date
    Jun 2010
    Location
    Here
    Post Thanks / Like
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)

    Default

    Check the power steering fluid level and the voltage across the battery with the engine running, should be 13.5-14.4v, is where i would start.

  3. #3
    Regular Member
    Join Date
    Mar 2009
    Location
    kilmarnock
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

  4. #4
    Regular Member alcutler's Avatar
    Join Date
    Nov 2010
    Location
    East Midlands
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by DasArab View Post
    Check the power steering fluid level and the voltage across the battery with the engine running, should be 13.5-14.4v, is where i would start.
    Agree with this I had similar with my 1.9 cdti (120) estate just returning home from a 100 mile no problem journey - stopped at a junction and warning light came on dash and lost power steering for a few seconds. Tried power steering fluid and connections to power steering pump as previously suggested - but in the end replaced the alternator and battery and never had problem since.
    I changed the alternator first, ran a diagnostic check and found it was showing a fault on the charging system. Eventually replaced the battery and been fine since. Oddly enough the old battery was a Bosch 90 amp hour one - I replaced it with a genuine GM one for my vehicle and this is only rated at about 70 amp hour, so I assume there was a mismatch between the alternator and the battery that threw up that fault. The Bosch battery was put on another car I have and went through the last extreme winter without a problem.
    Seems that the alternator / battery setup is quite sensitive on the Vectra and this can affect the power steering in the way you describe.
    Good luck with it!

  5. #5
    Regular Member
    Join Date
    Mar 2010
    Location
    Lincs
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks chaps, i did check the level at the time and it was fine. I'll check the battery next.

    Thank you.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Power Steering Failure
    By MadOnVaux! in forum Suspension, Wheels & Brakes
    Replies: 38
    Last Post: 17th December 2011, 23:40
  2. Power Steering Failure
    By derrybulmers in forum Suspension, Wheels & Brakes
    Replies: 1
    Last Post: 9th August 2011, 20:10
  3. Power steering failure
    By Chris06v6 in forum Engine & Drivetrain
    Replies: 15
    Last Post: 28th July 2011, 06:22
  4. Power Steering Failure
    By Medc in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 16th November 2010, 12:19
  5. Power Steering Failure
    By gsi.vxr in forum Engine & Drivetrain
    Replies: 10
    Last Post: 26th October 2010, 15:01

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •