User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Need help with Z20net oil leak!!

  1. #1
    New Member Turbovec's Avatar
    Join Date
    Mar 2011
    Location
    Ellesmere Port
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Need help with Z20net oil leak!!

    Hi peeps i need some help before i go spare.......
    I've got an oil leak on my Veccy and i am wondering if anyone else has had problems?
    The oil is running down the back of the engine from somewhere near the top and dripping off the bottom of the gearbox,but the oil is all over the both sides of the engine,so it's not just restricted to one side i think.
    I've changed the Rocker gasket and the Vacuum pump oil seal.
    I have noticed it gets worse if you drive a bit 'ahem' enthusiastically so i'm driving round like a sunday school teacher at the moment!!
    Oh and to make matters worse i pressure washed the engine to get some of the oil off and now the Engine Management light wont go out

  2. #2
    Regular Member Marcosuk's Avatar
    Join Date
    Dec 2009
    Location
    Fife
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    U checked the pipes to the oil cooler?? Is on the right hand side..

  3. #3
    Regular Member Jezzy's Avatar
    Join Date
    May 2009
    Location
    S.E
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you looked for the highest point on the engine where the oil is visible?

  4. #4
    New Member Turbovec's Avatar
    Join Date
    Mar 2011
    Location
    Ellesmere Port
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The prob is you just can't tell where it's coming from,i'm going to try the oil cooler pipes today and hope it's that but when you're underneath it because the drops of oil are everywhere i get the feeling they are being blown out under load from somewhere?
    There is oil probably as high up as just above where the cylinder head meets the block.
    Appreciate the help

  5. #5
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Check out around the main seal on the back of the engine. Mine needed to be replaced due to symptoms just like you describe.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil leak 150 cdti oil leak help
    By sr_fly in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 14th July 2011, 20:46
  2. Need an ECU - z20net
    By ephidor in forum Engine & Drivetrain
    Replies: 5
    Last Post: 23rd September 2010, 11:23
  3. Will this fit my Z20NET?
    By Caveman_nige in forum Petrol Engine related
    Replies: 8
    Last Post: 29th August 2010, 13:13
  4. Leak, front end creak, refurb, bent locking wheel key and another leak =(
    By nick-v2.2 in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 15th February 2010, 19:58

Visitors found this page by searching for:

z20net oil pump problem

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •