User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Crap in Air filter?

  1. #1
    Regular Member
    Join Date
    Mar 2011
    Location
    South Normanton, Debryshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Crap in Air filter?

    Hi,

    My brothers just took my car to a garage cause the other day the engine managment light came on so the car was going into that limp mode whatever its called lol That light has gone off but the emmissions light is now on. The bloke checked it all and said like the fuel pump, turbo etc was fine but theres crap in the air filter would this be right in thinking that when you put your foot down the car would go into the limp mode again but without the management light coming on?

    Just wanted some others peoples advice aswell to make sure lol

    Cheers Alan.

  2. #2
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    Limp Mode - Should a serious fault occur, the relevent ECU may allow the vehicle to run only on a very basic and highly limited setting - enough to get you home or to a garage.

    I think you need to be a tad more specific about 'crap in the air filter'.

    What kind of crap?

    Actually lodged in the filter element or just in the lower section of the housing?

    If the fault suspect was the fuel pump then I doubt if the air filter has anything to do with the actual fault.

    Which engine are we dealing with?

  3. #3
    Regular Member
    Join Date
    Mar 2011
    Location
    South Normanton, Debryshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Im not sure i wasnt there as im at work at the moment.

    From what my brother said theres just dust but i couldnt tell you where abouts all i know is that the guy checked everything like the fuel pump and the turbo etc so i was told! and they are working fine and he said theres dust and that in the air filter so changing that will probs solve the problem. Its only when you put your foot down it wont rev over 3000rpm.

    And my car is a 2.0DTI. Sorry but i dont know alot about cars so im probs not saying half the stuff right lol.

  4. #4
    Regular Member sri matt's Avatar
    Join Date
    Apr 2011
    Location
    dundee
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    first thing to do is get the stored fault codes, and go from there, very unlikly to be a dirty air filter, but for what is worth , you'll be as well changing it

  5. #5
    Regular Member
    Join Date
    Mar 2011
    Location
    South Normanton, Debryshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by sri matt View Post
    first thing to do is get the stored fault codes, and go from there, very unlikly to be a dirty air filter, but for what is worth , you'll be as well changing it
    thats what he was meant to do i thought it was gunna be put on some sort of computer probs the tect 2 one i keep hearing about but i dont think i had that done by the sounds of it a nice waste of £35 init lol

  6. #6
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The air filter is designed to trap dust, dirt, leaves, etc
    All this rubbish should be underneath the filter
    Good housekeeping is to either remove the housing and tap it clean, or to hoover it out
    If you do remove it, make sure you reconnect the water trap pipe

    I would now examine the MAF to make sure nothing has got past the air filter and has blocked the MAF, between the air filter housing and MAF

  7. #7
    Regular Member
    Join Date
    Mar 2011
    Location
    South Normanton, Debryshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by m8internet View Post
    The air filter is designed to trap dust, dirt, leaves, etc
    All this rubbish should be underneath the filter
    Good housekeeping is to either remove the housing and tap it clean, or to hoover it out
    If you do remove it, make sure you reconnect the water trap pipe

    I would now examine the MAF to make sure nothing has got past the air filter and has blocked the MAF, between the air filter housing and MAF
    If it has blocked the MAF would this cause the problem i have or would it still be something completely different?

  8. #8
    Regular Member
    Join Date
    Mar 2011
    Location
    South Normanton, Debryshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    So today changed the air filter and cleaned out the air box has there was some stuff in there and the car is still doing the same, The bloke my brother took it to appartently put a new MAF sensor on to check that but it was still doing it so he put my old one back on has anyone esle got any suggestions has its been tested and nothing came up either?

  9. #9
    Regular Member chewy71's Avatar
    Join Date
    Sep 2010
    Location
    Lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I crapped in mine but no spanner light came up - not advised tho.

  10. #10
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by sri matt View Post
    first thing to do is get the stored fault codes, and go from there
    Assuming the engine is still going straight into Engine Warning and/or safe mode, has this been done yet?

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. oh crap !!!!
    By wildchild in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 21st April 2012, 18:47
  2. 3 ltr V6.... crap?
    By Mr Hyde in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 22nd July 2011, 21:54
  3. is this crap or what
    By chinky in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 19th September 2008, 20:29
  4. Crap :(
    By Sawyer Reynolds in forum The 'Off Topic' room
    Replies: 22
    Last Post: 17th July 2008, 15:18

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •