User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: vectra cdti 150 help!

  1. #1
    Regular Member
    Join Date
    Mar 2011
    Location
    Stamford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default vectra cdti 150 help!

    ok so im driving home this morning doing about 85 and all of a sudden i start loosing power, im low on fuel screen says 20 miles left so i thought i had a fuel surge. i pulled off the motorway and there is this horrible knocking like a diesel knock and loss of power i got the car home and now it wont start. ive put more fuel in but no joy. ive been told its the egr valve but ive cleaned it and its free and yes i know they can cause it to not start but knock?????

    any ideas as the knocking is worrying me. cars done 90,000 has full service history and up untill now was running a treat all stock exept k and n filter and irmscher back box. oh also no lights came up on the dash??

    also if you try to start the engine with the egr removed loads of white smoke that stinks of bbq comes out of the metal pipe the egr connects to??

    need sorting asap as better half is pregnant and need it to get her to hospital etc as its our main car.

    Thanks
    Chris

  2. #2
    Regular Member jimbojetset's Avatar
    Join Date
    Aug 2010
    Location
    Stoke on Trent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Loss of common rail pressure or blocked injectors can also cause diesels not to start and knock when they do... white smoke can also be an indication of blocked injector/s... This ties in somewhat with your low fuel... maybe you've sucked up some muck from the bottom of your tank and blocked the filter or injectors...

  3. #3
    Regular Member
    Join Date
    Mar 2011
    Location
    Stamford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by jimbojetset View Post
    Loss of common rail pressure or blocked injectors can also cause diesels not to start and knock when they do... white smoke can also be an indication of blocked injector/s... This ties in somewhat with your low fuel... maybe you've sucked up some muck from the bottom of your tank and blocked the filter or injectors...

    when you try to start it with the egr removed it poors out white smoke, will check the filter housing out now thanks for the heads up.

    oh there is hardly any pressure at the injectors when you undo the unions and crank the engine this ties in with what you say no?

    Thanks again
    chris

  4. #4
    Regular Member
    Join Date
    Mar 2011
    Location
    Stamford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by DTORU View Post
    when you try to start it with the egr removed it poors out white smoke, will check the filter housing out now thanks for the heads up.

    oh there is hardly any pressure at the injectors when you undo the unions and crank the engine this ties in with what you say no?

    Thanks again
    chris
    Ok so changed the filter and primed it but still wont start there is fuel to the injectors but it just cranks but no start????

    please help??

    Thanks
    Chris

  5. #5
    Regular Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you checked the cambelt?

  6. #6
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP NAV

    Engine : 1.9 CDTi 150

    Year : 2007

    Default

    Is the EGR back on while your testing it now..?

  7. #7
    Regular Member
    Join Date
    Mar 2011
    Location
    Stamford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yes the egr is back on. Had the fault codes checked the below came up:
    Generator control circuit
    Fuel pressure regulator
    Fuel temp
    Fuel dossing sv
    Intake flow swirl throttle
    Fuel pressure rail


    Any ideas??? ****ed ecu maybe?
    Thanks
    Chris

    Really need this sorting at like I say other half nearly ready to drop with our first child and main car.

    Thanks again for all the help your a great bunch

  8. #8
    Regular Member
    Join Date
    Mar 2011
    Location
    Stamford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yes the egr is back on. Had the fault codes checked the below came up:
    Generator control circuit
    Fuel pressure regulator
    Fuel temp
    Fuel dossing sv
    Intake flow swirl throttle
    Fuel pressure rail


    Any ideas??? ****ed ecu maybe?
    Thanks
    Chris

    Really need this sorting at like I say other half nearly ready to drop with our first child and main car.

    Thanks again for all the help your a great bunch

  9. #9
    Regular Member
    Join Date
    Jul 2007
    Location
    southampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you checked the swirl valve control bar is conected on the inlet, sounds similar to the problem i had.

  10. #10
    Regular Member
    Join Date
    Mar 2011
    Location
    Stamford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ok so an update the garage have found a fault and are saying it's the inlet manifold that's wrong? Can this cause a diesel knock and not starting ? I know it causes lack of power but not sure about the knock it was just like an old mechanical diesel knock when fueling or timing is out. Timing on car was fine to. Egr is new to.

    Thanks
    Chris

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9 Vectra CDTi 150 VS 2.0 CDTi 160 insignia Sri
    By Derek Mc in forum Vectra C / Signum Car Chat
    Replies: 16
    Last Post: 12th May 2011, 11:38
  2. Vectra 1.9 CDTI Sri Versus 3.0 CDTI V6 Sri
    By collateral in forum Vectra C / Signum Car Chat
    Replies: 50
    Last Post: 21st April 2009, 20:18
  3. FS - Vectra SRI CDTI 150
    By rscosworth in forum Cars for sale
    Replies: 10
    Last Post: 16th July 2006, 22:11

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •