User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: 1.8 vectra 2002 speedo probs

  1. #1
    New Member
    Join Date
    Sep 2006
    Location
    MILTON KEYNES
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 1.8 vectra 2002 speedo probs

    hi all
    my vectra 1.8 suddenly puts all the speedo and rev dials to zero.it'll also
    lock out the indicators as well as putting the abs light on .this happens mainly when it's cold. everything can be re set by re starting the engine,then its ok.Any one out there had this?
    Incidently if anyone has a problem with the engine cutting to idle on these cars, replace the brake pedal switch and it'll cure it !!

  2. #2
    Regular Member david-bell's Avatar
    Join Date
    Sep 2005
    Location
    eastlothian scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra vxr

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2008

    Mileage : 31000

    Default

    check this thread out eddie link

  3. #3
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    all those faults point to the C.I.M. module..

    get it in to VX to get it checked, but be ready for a big bill if it has gone.. all the keys will need programming to the module.

    PIMM has just told me he's had to have one fitted.. cost him over 400 quid..


    As far as i know there is no aftermarket solution to this..


    the link to the other thread is how rorycarz fixed his dropping dials..

  4. #4
    Regular Member
    Join Date
    Mar 2006
    Location
    SOMERSET
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Gsi3.2
    all those faults point to the C.I.M. module..

    get it in to VX to get it checked, but be ready for a big bill if it has gone.. all the keys will need programming to the module.

    PIMM has just told me he's had to have one fitted.. cost him over 400 quid..


    As far as i know there is no aftermarket solution to this..


    the link to the other thread is how rorycarz fixed his dropping dials..
    Mark is right. It's NOTHING to do with the abs plug behind the battey. I had this problem for 1 month and it got worse every other day.I took the car to the stealers and they plugged her in and it was the C.I.M(control information unit) at fault.
    They fitted the new one which cost £236.00 and charged me £96.00 for the pleasure(i just got my receipt out).
    Since then, no more problems. I will bet you that is defferintly the problem with yours.

    Best of luck

    Heath

  5. #5
    Regular Member
    Join Date
    Mar 2006
    Location
    SOMERSET
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Gsi3.2
    all those faults point to the C.I.M. module..

    get it in to VX to get it checked, but be ready for a big bill if it has gone.. all the keys will need programming to the module.

    PIMM has just told me he's had to have one fitted.. cost him over 400 quid..


    As far as i know there is no aftermarket solution to this..


    the link to the other thread is how rorycarz fixed his dropping dials..

    That did included a new battery that i needed...

  6. #6
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sorry H..

    I remembered the figure , but forgot it included the battery..


  7. #7
    New Member
    Join Date
    Sep 2006
    Location
    MILTON KEYNES
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks all you guys.I discovered this morning that it also puts the lights on by itself .This is a typical computer type malfunction so it's probably this module thingy.I'm getting it to the dealers asap and I'll let you know what happens.

    cheers eddie

  8. #8
    New Member
    Join Date
    Sep 2006
    Location
    MILTON KEYNES
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default speedo probs

    took the car to dealers and yes the cim was duff.cost me over £400
    but it's ok now.
    best wishes eddie

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra C 2002 Y20DTH Remap DTI 2.0 2002
    By richardkay007 in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 8th February 2012, 14:18
  2. Electrical probs 2.2 sri 2002
    By ratbob in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 5th February 2010, 18:40
  3. 2002 Vectra Sri 2.2 16v
    By zeadly in forum Cars for sale
    Replies: 5
    Last Post: 27th September 2007, 21:18
  4. Vectra 2.6 Siemens Sat nav Probs
    By wonga55 in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 9th June 2007, 22:01

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •