User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Is blower motor resistor pack same on climate control models?

  1. #1
    Regular Member Partyvan's Avatar
    Join Date
    Oct 2010
    Location
    Nottingham M1 J26
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Is blower motor resistor pack same on climate control models?

    As title my last Vec C (normal heaters) blew the resistor pack, I swapped it no problem.

    My new Vec C has digital climate control, is it the same procedure, same part etc...?

    Thanks

  2. #2
    Regular Member benwalters82's Avatar
    Join Date
    Nov 2009
    Location
    Redruth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SXI

    Engine : 2.0DTI

    Year : 2002

    Default

    No - and much more expensive to fix

  3. #3
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As above completly different setup.

  4. #4
    Regular Member Partyvan's Avatar
    Join Date
    Oct 2010
    Location
    Nottingham M1 J26
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks guys. It refuses to blow on any setting, any idea what the problem is?

  5. #5
    Regular Member markj23's Avatar
    Join Date
    Aug 2010
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Partyvan View Post
    Thanks guys. It refuses to blow on any setting, any idea what the problem is?
    sounds like you married her lol well thats what happend to me lol

  6. #6
    Regular Member markj23's Avatar
    Join Date
    Aug 2010
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    is your carpet wet? has you scuttle drain been cleared? did it stop suddenly

  7. #7
    Ex Vec-C Admin Ian-Highlander's Avatar
    Join Date
    Jun 2008
    Location
    Ely, Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    57 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Tourer

    Trim : Elite

    Engine : 2.0 CDTI (160ps)

    Year : 2010

    Default

    Quote Originally Posted by markj23 View Post
    sounds like you married her lol well thats what happend to me lol
    "Doing a good job here is like wetting your pants in a dark suit, you get a warm feeling but nobody else notices"
    Maptun Tuned 2.0T Estate - click HERE for mods list.
    Brentwood 2012: Winner, Saturday Show. Hull 2012: Winner, Best Estate. Hull 2013: Winner, Best Estate & Runner Up, Best I.C.E

    Now Gone, bring on the Insignia (now "Teapot" Tuned)...

  8. #8
    Regular Member Partyvan's Avatar
    Join Date
    Oct 2010
    Location
    Nottingham M1 J26
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by markj23 View Post
    is your carpet wet? has you scuttle drain been cleared? did it stop suddenly
    I noticed the pollen filter isn't sat right, so might be a water leak

    I dont know when it failed, it just refused to work the other day when I turned the blowers on (first time ive tried since owning the car)

  9. #9
    Regular Member markj23's Avatar
    Join Date
    Aug 2010
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I would check the scuttle drain the drop the glove box and remove the parts where the resistor is and give a good clean out with contact cleaner
    then try it as this is what someone else did and it worked otherwise its 180 quid

  10. #10
    Regular Member Partyvan's Avatar
    Join Date
    Oct 2010
    Location
    Nottingham M1 J26
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by markj23 View Post
    I would check the scuttle drain the drop the glove box and remove the parts where the resistor is and give a good clean out with contact cleaner
    then try it as this is what someone else did and it worked otherwise its 180 quid
    Thanks, i'll give this a try.

    I assume it's 4 or 6 screws to remove glovebox then it's a resistor pack tucked away somewhere? Not sure what im looking for, although I did do this on a non-climate Vec C

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Blower Motor Resistor
    By VectraMikey in forum Electrical & ICE (including SatNav)
    Replies: 8
    Last Post: 28th November 2012, 09:23
  2. Blower Resistor pack
    By jammy_c in forum Bodywork & Interior
    Replies: 1
    Last Post: 16th October 2012, 20:00
  3. HELP! Climate Control Resistor Needed!!!
    By bartsisgod in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 3rd July 2010, 07:34
  4. climate control resistor pack location
    By monkyspunky in forum Troubleshooting
    Replies: 1
    Last Post: 19th July 2009, 19:19
  5. motor resistor pack
    By timbarny in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 9th June 2008, 17:17

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •