User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Subwoofer and Amp installed :)

  1. #1
    Regular Member mickydoos's Avatar
    Join Date
    Aug 2009
    Location
    Crawley, West Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Subwoofer and Amp installed :)

    I'll just redirect you to the thread I started in the ICE gallery section as I know far more people check this section

    http://www.vectra-c.com/forum/showthread.php?t=133147

  2. #2
    Regular Member
    Join Date
    Apr 2010
    Location
    Sale
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Hatchback

    Trim : Sri

    Engine : 1.8vvt

    Year : 2008

    Default

    I love that first power up moment when you try a new sound system add on - not so much the pressure on the ears after an enthusiastic drive.

  3. #3
    Regular Member mickydoos's Avatar
    Join Date
    Aug 2009
    Location
    Crawley, West Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just to finally get it in and working. I bought the sub maybe 9 months ago? As I've been buying stuff bit by bit due to slightly limited budget. Nonetheless. Loving it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gid installed
    By Al 22 dti in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 21st March 2011, 17:53
  2. How to tell if theres a re-map installed???
    By cammy3000 in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 31st January 2011, 16:27
  3. HIDs Installed ish
    By JSYSH466Y in forum Styling
    Replies: 26
    Last Post: 5th February 2009, 23:57
  4. New ICE installed
    By Caterman in forum ICE Gallery
    Replies: 21
    Last Post: 22nd September 2006, 04:14
  5. Subwoofer installed
    By DennisTheMenace in forum Quick Photo Album
    Replies: 5
    Last Post: 1st June 2006, 15:55

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •