User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: EGR replaced. Now the car is running worse

  1. #1
    Regular Member Lao's Avatar
    Join Date
    Aug 2009
    Location
    Romania, E.U.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate Automatic

    Trim : Elegance

    Engine : Z19DTH

    Year : 2005

    Default EGR replaced. Now the car is running worse

    Yesterday I replaced the EGR with a new one, but after I got the car on the road, it behaves much worse than it did with the modded EGR I had (removed the pin that pushed the valve).

    Although I had the EML light ON all the time, the car was running great.

    Now the EML is off, new EGR fitted, but when I drive it, around constant 1700-1900 rpm I get some really bad jerks and a strange noise comes out, I think from the turbo.

    If I accelerate, the car goes like it should. But if I stick to 1800 rpm I have these jerks and noises (something like ch-ch-ch on every jerking).


    I would like to put back the old (and better) EGR to see if I still have the jerking.


    Anyone know what could be the problem?

  2. #2
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Why did you remove the pin from the egr?

    Isnt that what you need to regulate the gas flow?

  3. #3
    Regular Member Lao's Avatar
    Join Date
    Aug 2009
    Location
    Romania, E.U.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate Automatic

    Trim : Elegance

    Engine : Z19DTH

    Year : 2005

    Default

    Old EGR wasn't working as it should, so I tried this solution on my own. Apart from EML light which was always ON since, the car was running much better.

    I wanted to see if it works better with a new EGR I had lying around for 6-7 months. Well... it doesn't run better, that's for sure, but I can't figure out what's wrong. I don't think it's the new EGR's fault, because it's brand new.

  4. #4
    Full Member GazVXLINE170's Avatar
    Join Date
    Jun 2007
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRI VX-Line Nav

    Engine : 2.0 CDTI [170 PS]

    Year : 2015

    Mileage : 27000

    Default

    When you replace the EGR valve you are supposed to have an engine update. Sounds like the one you have fitted is jamming open.

    Gazza4
    Insignia VX-Line Nav CDTI 170.

  5. #5
    Regular Member Lao's Avatar
    Join Date
    Aug 2009
    Location
    Romania, E.U.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate Automatic

    Trim : Elegance

    Engine : Z19DTH

    Year : 2005

    Default

    Are you referring to the ECU's software? You saying it need updating?

  6. #6
    Full Member GazVXLINE170's Avatar
    Join Date
    Jun 2007
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRI VX-Line Nav

    Engine : 2.0 CDTI [170 PS]

    Year : 2015

    Mileage : 27000

    Default

    Quote Originally Posted by Lao View Post
    Are you referring to the ECU's software? You saying it need updating?
    Yip. Simply replacing the valve may not correct the problems. Also ontop of it does the valve actually move freely?

    Gazza4
    Insignia VX-Line Nav CDTI 170.

  7. #7
    Regular Member Lao's Avatar
    Join Date
    Aug 2009
    Location
    Romania, E.U.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate Automatic

    Trim : Elegance

    Engine : Z19DTH

    Year : 2005

    Default

    I'll check it tomorrow. I put too much confidence in it being new.

  8. #8
    Regular Member
    Join Date
    Feb 2011
    Location
    derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Im having the exact same problem at the minute as well, the symptoms are the same and its now worse after i replaced the egr. So if you find the cure let us know how you get on.

  9. #9
    Regular Member
    Join Date
    Feb 2010
    Location
    CHESHIRE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Gazza4 View Post
    When you replace the EGR valve you are supposed to have an engine update. Sounds like the one you have fitted is jamming open.

    Gazza4
    arite gazza4 , those this apply if your running the latest software update , reason i ask thinking of getting a new egr valve off ebay .

  10. #10
    Full Member GazVXLINE170's Avatar
    Join Date
    Jun 2007
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRI VX-Line Nav

    Engine : 2.0 CDTI [170 PS]

    Year : 2015

    Mileage : 27000

    Default

    Quote Originally Posted by dave r View Post
    arite gazza4 , those this apply if your running the latest software update , reason i ask thinking of getting a new egr valve off ebay .

    Technically when you replace a component in an engine these days you should 'let' the ECU know the component has been changed. You may get away with a software update and repalcing the valve later but I'm not 100%.

    Gazza4
    Insignia VX-Line Nav CDTI 170.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Z18XER Burnt valves replaced/ still not running right
    By aeu9921 in forum Engine & Drivetrain
    Replies: 17
    Last Post: 5th February 2013, 22:08
  2. Worse job ever ?.......
    By martyngell in forum Y & Z30DT Specific
    Replies: 2
    Last Post: 2nd August 2012, 19:55
  3. White smoke getting worse and worse
    By alphabravo in forum Troubleshooting
    Replies: 3
    Last Post: 19th March 2011, 01:04
  4. Its getting worse..........
    By bobby-tupper in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 27th January 2009, 18:23
  5. Bad to worse!!!!!!!
    By Caterman in forum General Chat
    Replies: 27
    Last Post: 25th December 2007, 06:52

Visitors found this page by searching for:

new egr valve car worse

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •