User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Alternator problems??

  1. #1
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default Alternator problems??

    Driving home tonight battery light came on as well as the dreaded spanner light switched it off and on and it went off but came back on 10 mins later
    put opcom on it and the battery shows 12v but drops to11.5v when the engine is running
    the alternator was replaced at vx under warrenty in august 07 the car has only done 35k since that dte you would have a thought these alternators would last longer then that and these aint cheap to replace
    the trade club book lists 6 replacement units which go up in price according to amp rating but i dont know what amp rating mine is
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  2. #2
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    hopefully will be fixed today
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  3. #3
    Regular Member GTS's Avatar
    Join Date
    Oct 2010
    Location
    Poland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine got broken after about 40k miles so it may be typical :/

  4. #4
    Regular Member
    Join Date
    Feb 2011
    Location
    lincolnshire,sleaford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Cdti

    Trim : Sri

    Engine : 1.9

    Year : 2005

    Default

    my alt went at 33000 on my 05 sri in feb good job it was still under warrnaty

  5. #5
    Regular Member john_k_sri's Avatar
    Join Date
    Oct 2006
    Location
    Waterloo, Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI NAV XP

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 72K

    Default

    Mine went out of the blue at 49K. Red Battery light on solid, running voltage dropped to 11.5V. Replaced under Network Q.

    Appears to be a common problem with 1.9 CDTIs.

  6. #6
    Regular Member Hideous's Avatar
    Join Date
    Mar 2007
    Location
    GB
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i've said it many times before, but the vec c alternators are complete junk from the get go. crappest part that was ever fitted to a car in motoring history.
    it's not a case of if it will fail, but just a matter of when for the majority.
    yes, they really are a joke.
    there was a recall, but it didn't cover mine - and guess what, mine failed too.

  7. #7
    Regular Member
    Join Date
    May 2007
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Huh. Picked up 04 2.2 dti Signum Elite to replace my knack'd 2.0 dti Vectra on thursday, got 3 miles from home, battery light on solid, got home all sorts of lights on, game over, dead.

    Put battery on charge overnight. Just enough to get it started and parked on the street for the recovery truck back to the dealer! He brought the vectra back for me to have over the weekend while he gets it fixed.

    Looks like at least new alternator, probably the battery as well, seeing how quickly the voltage dropped.

    Good start.

    Peter
    Last edited by peterholton; 20th March 2011 at 12:52.

  8. #8
    Regular Member robengland9's Avatar
    Join Date
    Feb 2011
    Location
    london
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    when my alternator went on my Vec cdti 2006 deisel... i got a brand new one from ebay £99 next day delivery not original part. Fitted myself in 2 hours and I'm no mechanic. Vauxhall dealer price would be about £400 fitted and the original alternators are crap....

  9. #9
    Full Member
    Join Date
    Mar 2011
    Location
    n. ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    when i bought my 07 sri estate battery light came on during the test drive 62,000 on the clock stil bought the car once they replaced the alternator

  10. #10
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default

    Chris now has a shiney new Alternator fitted

    Me and Chris did the job this morn - hours job, pretty straight forward really.


Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Alternator Problems
    By scottc in forum Electrical & ICE (including SatNav)
    Replies: 21
    Last Post: 8th December 2012, 16:22
  2. alternator problems
    By tyler boy in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 10th November 2011, 19:19
  3. alternator problems
    By webtrawler in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 29th September 2011, 08:09
  4. alternator problems
    By bran.c in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 20th January 2009, 23:50
  5. Alternator problems
    By AJA in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 27th August 2006, 07:58

Visitors found this page by searching for:

shandon electrical alternator cost

vauxhall vectra c alternator problems

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •