User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Heater constantly blowing hot!!!!!

  1. #1
    Full Member axelf's Avatar
    Join Date
    May 2009
    Location
    chester le street
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Exclamation Heater constantly blowing hot!!!!!

    Hi wonder if any 1 can help, my father in law has 1.8 54 plate vectra.... it has just started blowing hot air when the temperature has been selected to cold.... even with the air con on..... we cant get it to blow cold at all... Has any 1 had the same problem any help will be great....
    Thanks....

  2. #2
    Regular Member jonnybravo's Avatar
    Join Date
    Jul 2009
    Location
    barnsley,yorkshire,GB
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum


    Engine : 20 Dti


    Default

    Hi Axelf
    not done one myself but there is a air distribution drive servo motor that positions the air deflector flap that directs cold/hot air in to the cabin,may be a fault in motor or a wiring break in the supply line,as i say not done one myself.

  3. #3
    New Member
    Join Date
    Oct 2009
    Location
    essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have just found out that i've got exactly the same problem with my 2004 53 plate 1.8 club

  4. #4
    Regular Member
    Join Date
    Oct 2008
    Location
    Reading
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Had this problem a couple of years ago, If you take the trim panel off at the side of the centre console, in the passenger footwell, under the glovebox, you will see a red plastic linkage, this is the heat control flap actuator thing, I found mine had come unclipped, simply put it all back together and gave it a liberal dosing of WD40 and its been fine since.

  5. #5
    New Member
    Join Date
    Oct 2009
    Location
    essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by jonnybravo View Post
    Hi Axelf
    not done one myself but there is a air distribution drive servo motor that positions the air deflector flap that directs cold/hot air in to the cabin,may be a fault in motor or a wiring break in the supply line,as i say not done one myself.
    have been told that this drive servo motor has failed on mine. Can anyone let me know where I might be able to get one from without having to resort to the stealers.

    Any help will be most gratefully received

  6. #6
    Regular Member wingz123's Avatar
    Join Date
    Mar 2011
    Location
    M4 Junc 12
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi mate...

    I have just posted a thread...didn't see yours first... but I am getting the same problems (see below)

    Hi all,

    I am fairly new to this forum and I picked up my 04' plate Vectra estate 2.0 dti on Friday.

    Now the problem lies with the heater...

    You have the option of different heater speeds e.g 0,1,2,3 and 4 i believe

    When on 0 the heater is still at speed 1.

    AND

    blowing out sweltering hot air even when you turn the central dial from hot to cold.

    What could this be? please help!

  7. #7
    New Member
    Join Date
    Jan 2011
    Location
    Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had the same problem on my 05 CDTi 120. I removed the glovebox, side trim and the air distributer. then I took the assembly apart - disconnected the red link from the 'flap' and removed the motor. At this point i moved the flap by hand and the air switched from hot to cold, so obviously problem with the motor. I took apart the motor, didn't do much with it, put it back together and plugged it into the connector and it worked. Put it all back together and it works great.

    Now, be careful - there are a lot of delicate parts, i broke a few of them, i'm lucky that i have a plastice welder though. also, when you take apart the motor unit, there are many gears in there, dont let the fall out.

    Sorry this is not a great explanation but it is by memory and I should be working right now

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. heater fans not blowing
    By Jaspa in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 3rd December 2011, 16:37
  2. Heater constantly hot. Help?
    By Critch in forum Vectra C / Signum Troubleshooting
    Replies: 8
    Last Post: 8th October 2011, 11:28
  3. heater blowing warm
    By keithv1 in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 3rd December 2010, 17:09
  4. Internal Fan / Heater Constantly on !
    By avitohyes in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 4th June 2009, 21:36
  5. Heater only blowing Hot Air
    By DaveVectraSRI in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 22nd February 2009, 15:47

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •