User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: How can I tell if my thermostat is realy gone?

  1. #1
    Regular Member PeterVV's Avatar
    Join Date
    Oct 2007
    Location
    south wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default How can I tell if my thermostat is realy gone?

    Heres the thing my temp guage has been a little sluggish of late, butdoes rise to around the 92 ish mark ( which is the contro temp for the stat?), but it is taking a long time to register, and then goes up quickly, then when I am cruising the temp drops back down to zero?
    there is hot air coming in the cabin, so is the stat faulty, I havent heard the fan cut in yet, which may be an issue.
    Now the problem for me is that the engine is the 1.8 ZER ( vvt model ), and the stat unit with temp sender is over £100!, and dont want to spend that much if its not needed.
    I believe that the stat is controled by various sensors feeding back info to the engine management ,so is it my stat, faulty senser, temp sender unit?

  2. #2
    Regular Member PeterVV's Avatar
    Join Date
    Oct 2007
    Location
    south wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Anyone?

  3. #3
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    the temp shouldn't drop back down below 85 even when cruising on the mway with the heating on...
    my cdti stat was doing just the same, now replaced it has not dropped back down once up to temp

  4. #4
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Quote Originally Posted by dh.dti View Post
    the temp shouldn't drop back down below 85 even when cruising on the mway with the heating on...
    my cdti stat was doing just the same, now replaced it has not dropped back down once up to temp
    Same here

  5. #5
    Regular Member markj23's Avatar
    Join Date
    Aug 2010
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    just change it so your mind is at rest they are not expensive

  6. #6
    Regular Member
    Join Date
    Apr 2007
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : CDTI 150

    Trim : Design

    Engine : Z19DTH

    Year : 2005

    Default

    How can I tell if my thermostat is realy gone?

    Remove the stat, place in a pan of water and heat.
    Place a thermometer in the pan and note at what temp the stat opens.

  7. #7
    VIP-Member
    Join Date
    Dec 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats



    Engine : Z18XER


    Default

    Quote Originally Posted by markj23 View Post
    just change it so your mind is at rest they are not expensive
    They are on this engine it is controlled electrically and can only buy complete
    in housing

  8. #8
    Regular Member markj23's Avatar
    Join Date
    Aug 2010
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    if you think its gone 99 times out of 100 it has !!!! 80 quid is not expensive against a poorly running car that will be over fuelling and doing all sorts of damage to a 5k car

  9. #9
    Regular Member
    Join Date
    May 2010
    Location
    lutterworth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    the only time i can temp gauge to register anything is to leave on tick over for 15mins as soon as you move off needle drops to 0 with in 5mins of driving z18xer thermostat orderd

  10. #10
    Regular Member felixx's Avatar
    Join Date
    Mar 2010
    Location
    stockport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by markj23 View Post
    if you think its gone 99 times out of 100 it has !!!! 80 quid is not expensive against a poorly running car that will be over fuelling and doing all sorts of damage to a 5k car
    £80!!!,I got mine for £37 delivered,off ebay. FELIXX.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. realy bad knocking while coasting
    By tonner in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 15th November 2012, 22:45
  2. Realy I need help
    By ragytec in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 28th April 2011, 13:49
  3. Realy missing my car!!!
    By Jow20 in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 14th January 2011, 14:05
  4. Snowfoam, Is it realy worth it?
    By PeterVV in forum Detailing and Car Care Discussion
    Replies: 19
    Last Post: 9th August 2009, 20:05
  5. Realy Pi$$ed Off Now
    By ditchp in forum General Chat
    Replies: 38
    Last Post: 26th November 2007, 21:41

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •