User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: 2.2DTi down on power and mpg

  1. #1
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default 2.2DTi down on power and mpg

    Lately my mother has been complaining about the car being a bit sluggish and quite thirsty. MPG is right down to 32! That's with 60/40 town/motorway driving Used to be around 40 ish.
    I went for a drive earlier and it does feel sluggish, however, it doesn't smoke one bit. As I was turning into the car park the EML (limp mode, 2700rpm max) came on so I popped the diagnostic thing on and it said: Barometric pressure not plausible with boost pressure. I pushed on the boost sensor connector and the light went off, no more limp mode.
    Went for another drive and still sluggish...checked on the diagnostics and all was ok. Turned the engine off and set about fiddling with the computer

    On the center display the outside temperature read +10.5°C, BUT on the diagnostics it said that the outside temperature was -16.1°C!!!!

    It's an auto, but the gearbox is fine. I changed the fuel filter 3 weeks ago. Oil and air filter are due next month.


    I have to add that it's been a while since this engine sounded right. It's louder than most 2.2DTi's...and much louder than a neighbour's that has over 300k on it




    HELP?

  2. #2
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    72 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    Check turbo pies for small splits or nicks next change boost sensor HTH

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  3. #3
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Quote Originally Posted by bigmac View Post
    Check turbo pies for small splits or nicks next change boost sensor HTH
    Everything is fine there. No splits in either boost or vacuum pipes. Boost sensor is clean

  4. #4
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    72 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    Boost sensor could be faulty

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  5. #5
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Quote Originally Posted by bigmac View Post
    Boost sensor could be faulty
    If that, then I'd say failing rather than faulty, because the car never shows a fault code related directly to the boost sensor

  6. #6
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My 2.2dti was down to 32mpg but all it needed was good FULL service. afterwards I'm back up to 42mpg and I do about 75% dual carriage way 25% town driving.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Intermittant power loss on 2.2DTi
    By stevemann in forum Engine & Drivetrain
    Replies: 24
    Last Post: 14th November 2010, 11:42
  2. 2.2DTI losing power and knocking noise
    By Celes in forum Engine & Drivetrain
    Replies: 2
    Last Post: 5th April 2010, 03:25
  3. At last a 2.2DTi with real power!
    By John LE in forum Diesel Engine related
    Replies: 34
    Last Post: 10th December 2009, 17:50
  4. 2.2DTI Power loss and starting problem
    By grslewis in forum Engine & Drivetrain
    Replies: 2
    Last Post: 21st April 2008, 16:38
  5. 2.2dti power box
    By LAV6Y in forum Diesel Engine related
    Replies: 31
    Last Post: 23rd May 2007, 22:12

Visitors found this page by searching for:

2.2dti down on power

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •