User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Engine and Spanner Light Before I Start The Engine

  1. #1
    Regular Member corderz's Avatar
    Join Date
    Mar 2010
    Location
    Bradford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Engine and Spanner Light Before I Start The Engine

    Hey guys,

    I had both the engine light and the spanner light when i turn the ignition, but then go once i start the engine. Now only the spanner light comes up.

    Any ideas what i can check? nothing coming up on my fault code reader....

  2. #2
    Regular Member Rapala's Avatar
    Join Date
    Oct 2008
    Location
    Clackmannanshire Central Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Does the spanner light go off as soon as the engine starts?

  3. #3
    Regular Member corderz's Avatar
    Join Date
    Mar 2010
    Location
    Bradford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yes, but that spanner light doesnt come on anymore, its just the engine light now, then goes off

  4. #4
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As long as there are no warning lights on when the car has fired, there should be no problem.

  5. #5
    Regular Member Rapala's Avatar
    Join Date
    Oct 2008
    Location
    Clackmannanshire Central Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Talking

    Thats the way its meant to be, just the engine light on its own when you switch on the ignition then going off straight away when the engine starts. If the spanner light comes on and stays on then you have a fault, if the spanner light comes on with the ignition and it goes off as soon as the engine starts it is indicating that a fault has been present but it has cleared. If this was the case the spanner light will eventually stop coming on with the ignition after 25-35 engine starts if no other faults show up.
    Just to contradict the above if the spanner light comes up along with an oil can that is lit as well it is telling you that the car is due a service.

    The above makes sense I hope.
    Last edited by Rapala; 10th March 2011 at 12:04.

  6. #6
    Regular Member john_k_sri's Avatar
    Join Date
    Oct 2006
    Location
    Waterloo, Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI NAV XP

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 72K

    Default

    Quote Originally Posted by Rapala View Post
    Thats the way its meant to be, just the engine light on its own when you switch on the ignition then going off straight away when the engine starts. If the spanner light comes on and stays on then you have a fault, if the spanner light comes on with the ignition and it goes off as soon as the engine starts it is indicating that a fault has been present but it has cleared. If this was the case the spanner light will eventually stop coming on with the ignition after 25-35 engine starts if no other faults show up.
    Just to contradict the above if the spanner light comes up along with an oil can that is lit as well it is telling you that the car is due a service.

    The above makes sense I hope.
    Except that on facelifts the 'car and oilcan' icon is not used to indicate service due.

    The appearance of warning lights which disappear shortly after switching on the ignition and before starting the engine is part of a normal start-up diagnostics procedure. Perfectly normal.

  7. #7
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Quote Originally Posted by john_k_sri View Post
    Except that on facelifts the 'car and oilcan' icon is not used to indicate service due.
    Correct. The word InSP appears briefly in the odometer display instead when you first turn the key.

  8. #8
    New Member
    Join Date
    Jan 2011
    Location
    yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ho guys, I posted on another thread re this this week, my 05 1.9cdti has started doing this with the oilcan/spanner when starting and on shutdown, it was serviced by an independent about 2k ago, I have tried the reset listed on other threads but to no avail... Any thoughts anyone please it's really bugging me now

  9. #9
    Regular Member Rapala's Avatar
    Join Date
    Oct 2008
    Location
    Clackmannanshire Central Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Did you do it this way?
    Ignition off and press mileage reset button and hold it in, press the brake pedal down and hold it down. Now switch ignition to position two while still pressing the mileage button and the brake pedal until the service indicator resets.

  10. #10
    New Member
    Join Date
    Jan 2011
    Location
    yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I tried it with the ignition in pos 2, I will try it again as you describe and post back.. Many thanks... Fingers crossed. It says 1.000 under the spanner if that means anything

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. 2.0 DTI engine spanner light?
    By Thom in forum Engine & Drivetrain
    Replies: 12
    Last Post: 5th August 2011, 22:51
  3. Engine light, not spanner
    By Mr Hyde in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 25th March 2011, 13:49
  4. Engine Spanner Light And No Power
    By yamkwak in forum Engine & Drivetrain
    Replies: 39
    Last Post: 9th April 2008, 22:40
  5. car & spanner + emissions (engine) light
    By Nickzx6r in forum Engine & Drivetrain
    Replies: 4
    Last Post: 20th August 2006, 21:11

Visitors found this page by searching for:

spanner starts

spanner light before starting

Turn engine with spanner before start

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •