User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Vectra C 150 CDTi Lack of Power

  1. #1
    Regular Member
    Join Date
    Mar 2011
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra C 150 CDTi Lack of Power

    Hiya,

    I bought a Vectra C 150 CDTI yesterday and having driven it i have now noticed that it seems to lack power below 2250rpm, any ideas/common faults ???

    Many Thanks

  2. #2
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Take the engine vanity cover off and have a look down behind the fuel rail. You will see a metal rod. If it is lying there or has become detached then the manifold is needing replaced - common fault. If the rod is attached don't touch. I wouldn't be surprised you find lots of oil sweat there anyway.

    Other possibility is the EGR valve which inhibits power under 2,000rpm.

    Gazza4

  3. #3
    Regular Member
    Join Date
    Sep 2009
    Location
    middlesbrough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Remove and clean your egr valve and your boost sensor, have a look in the how 2

  4. #4
    Regular Member
    Join Date
    Mar 2011
    Location
    S
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Get the EGR valve cleaned. I had 1.9cdti SRI 150 and was losing power until finally it wouldnt go above 10mph!! Was a clogged up EGR valve.

  5. #5
    Regular Member
    Join Date
    Mar 2011
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    engine cover removed, and the metal rod is just lying there, not attached at all, does this now mean a new inlet manifold ????

  6. #6
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    you can bodge it up for a while, i think there's a howto... but yes you need a new manifold

  7. #7
    Regular Member ROY GBIV's Avatar
    Join Date
    Aug 2008
    Location
    The highways and byways
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by sclarkson82 View Post
    engine cover removed, and the metal rod is just lying there, not attached at all, does this now mean a new inlet manifold ????
    So the rod is off but the only effect is that the car is lacking power below 2500rpm?

  8. #8
    Regular Member
    Join Date
    Mar 2011
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    seems to be, why wats else cud there be, like i said not had car long

  9. #9
    Regular Member ROY GBIV's Avatar
    Join Date
    Aug 2008
    Location
    The highways and byways
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by sclarkson82 View Post
    seems to be, why wats else cud there be, like i said not had car long
    Nah, I was under the impression that if this failed the effect would be more noticable and catastrophic than a lack of power low down the rev range.

    I'm new to the 'C' as well. Knowing my luck mine has probably detached itself too!

  10. #10
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    Quote Originally Posted by sclarkson82 View Post
    engine cover removed, and the metal rod is just lying there, not attached at all, does this now mean a new inlet manifold ????
    Mt missus' car was like this. The swirl valves were stuck solid. Managed to push them into the "open" position for now, leaving the rod off (no oil sweat though). Number 3 still moves freely (motorised one?). The car runs fine, and pulls like a train, right through the rev range. Inlet manifold is my next job, though

    It was a little rough until I cleaned the EGR valve and boost sensor.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 3.0 v6 cdti 2004 lack of power
    By DONNAS5889 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 15th June 2011, 20:58
  2. Cdti lack of power engine sluggish
    By Diesel Dude in forum Engine & Drivetrain
    Replies: 6
    Last Post: 19th January 2011, 16:07
  3. Help needed Lack of Low Down Power cDTI 150
    By supersione in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 24th January 2010, 19:58
  4. Lack Of Power (2004 1.9 cdti 8V)
    By user999998 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 2nd June 2009, 09:03
  5. cdti 150 lack of power
    By michael cummings in forum Diesel Engine related
    Replies: 3
    Last Post: 8th February 2009, 20:44

Visitors found this page by searching for:

vectra c 1.9 cdti lack of power

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •