User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Weird brake/clutch probs..

  1. #1
    Regular Member mark_647's Avatar
    Join Date
    Jun 2008
    Location
    Wales, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Weird brake/clutch probs..

    Something odd happened last night, its done it once or twice before though..

    Went to use my brakes, they work fine but the pedal seemed stiff to depress. After pressing the initial inch or so, pedal feels normal. Happened a few times and then went back to feeling totally normal.

    Along with this, the clutch started to feel super smooth, I had to put zero effort into a smooth gear change, it felt like an auto. I will not the clutch did not slip at any point and all power was there, of not a little more power, it felt more tourquey ?

    Any ideas ? If I take this ti VX, they will not understand and just test drive the car and say there is nothing wrong as right now, its back to normal !?

    Ive done a few emg brakes, stops absolutely fine, strange.

  2. #2
    Regular Member mark_647's Avatar
    Join Date
    Jun 2008
    Location
    Wales, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Anyone ?

  3. #3
    Regular Member
    Join Date
    Aug 2010
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by mark_647 View Post
    Something odd happened last night, its done it once or twice before though..

    Went to use my brakes, they work fine but the pedal seemed stiff to depress. After pressing the initial inch or so, pedal feels normal. Happened a few times and then went back to feeling totally normal.

    Along with this, the clutch started to feel super smooth, I had to put zero effort into a smooth gear change, it felt like an auto. I will not the clutch did not slip at any point and all power was there, of not a little more power, it felt more tourquey ?

    Any ideas ? If I take this ti VX, they will not understand and just test drive the car and say there is nothing wrong as right now, its back to normal !?

    Ive done a few emg brakes, stops absolutely fine, strange.
    Reading the above is not clear at all.

    Brake pedal was this tested with engine running or not?

    Brake fluid if not been changed in the last two years replace as this contains moisture and when pressed can give poor performance and pedal travel.

    Smooth gear changes what the problem with that?

  4. #4
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    Have you got enough brake fluid in the reservoir.

  5. #5
    Regular Member Tam80's Avatar
    Join Date
    Aug 2010
    Location
    Dundee-Motherwell
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    When I Jump In Car 1st Thing In The Morning..Drive Maybe Bout A Mile Before I Need To Brake..When I First Hit The Brake Its Solid...But Its Ok After That

  6. #6
    Regular Member mark_647's Avatar
    Join Date
    Jun 2008
    Location
    Wales, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yer, its very odd. Happened again last night. I come to use my brakes (whilst driving) Brake pedal was very hard to depress the first inch or so, then becomes normal. At the same time as depressing the brake pedal, I feel the clutch pedal judder...

    Very odd problem, the brakes still work fine and the fluid is at the correct level.
    Ill see how it goes, im not too concerned about the brake performance, not once have they felt like they were letting me down.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clutch slipping and loosing clutch/brake fluid
    By marty_b0y in forum Engine & Drivetrain
    Replies: 15
    Last Post: 31st May 2012, 00:18
  2. clutch pedal feels weird
    By abz123 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 2nd April 2012, 21:05
  3. Brake probs
    By SteveH in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 21st August 2008, 18:20
  4. clutch gone weird
    By rayvo-gsi in forum Engine & Drivetrain
    Replies: 4
    Last Post: 17th August 2007, 11:42
  5. weird brake pad warning problem !!
    By veccy22 in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 7th June 2007, 20:14

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •