User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: Probs with instrument cluster??

  1. #1
    New Member
    Join Date
    Mar 2010
    Location
    Denmark
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Probs with instrument cluster??

    Hi everyone
    I have a problem with a vectra c with a z28net engine.
    When you are driving then suddenly the cluster goes black. Both the RPM, temp, gasoline, and Mph goes out and then comes on again. I have tried to change the CIM but tha result of this is that itīs actually got worse. The problem occurs 3 times within 2 minutes. My suspicion is the instrument cluster but this is rather expensive in Denmark where i live and so is the CIM so iīd rather have some inputs before i start ordering anything. Hope u guys can help me?

    Morner

  2. #2
    Full Member
    Join Date
    May 2009
    Location
    South West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    http://www.vectra-c.com/forum/showthread.php?t=126337

    Here you go mate. "touch wood" since i cleaned the plug to the CIM module, mine has not had a problem since.

    Takes 10 mins to do and could also do the trick for you too mate.

    Rgds
    Aidi

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dead instrument cluster
    By laney_2.2 in forum Electrical & ICE (including SatNav)
    Replies: 8
    Last Post: 18th August 2012, 09:15
  2. instrument cluster
    By waky in forum Electrical & ICE (including SatNav)
    Replies: 16
    Last Post: 3rd December 2011, 00:31
  3. instrument cluster
    By veccyv6 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 25th August 2011, 19:03
  4. Instrument cluster
    By Daywalker in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 8th November 2008, 18:43
  5. Instrument cluster
    By Daywalker in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 12th October 2008, 20:02

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •