User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: 2.2dti major idle problems

  1. #1
    New Member
    Join Date
    Mar 2011
    Location
    N.Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.2dti major idle problems

    Hi , I have a problem with my 2004 2.2dti (it has the electronic egr valve) when I start it in the morning it runs fine for about 30 seconds. Then it nearly cuts out every 2-3 seconds, the little air control valve(sorry I don’t know the proper name for it)on the inlet manifold keeps moving in and out causing the car to nearly stall, this continues for about 10mins until the car warms up, then it keeps doing it only a lot milder- the little valve is still moving in and out but not as much, this will continue most of the time even when driving, the only time its stop is when the spanner light comes on and the car go’s into limp mode. It was put on the computer, faults were with the egr and air flow meter, both these were changed for brand new Vauxhall ones. It made no difference, also the vaccum valve that controls the air control valve was changed and it did not help, when the weather is cold or damp there is more chance of going into limp mode, can anyone help please?? P.s this is a frontera, same engine as a vectra c

  2. #2
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Are you referring to valve circled below? :



    To stop the butterfly opening and closing I suggest disconnecting the vacuum pipe and put a screw in the end of it. The Butterfly will stay open permanently but you will notice more of a judder when you switch off the engine. The butterflys purpose its to just make it smoother when you switch the engine offl

    Obviously you have a bigger problem going on some where and this fix is an attempt to solve a symptom of what I think is something else.

    You may have an air leak in one of your vacuum pipes. I suggest checking the length of the pipes. I've never heard of a leak causing that much of a reaction though. Here is a link on a thread I started awhile back about replacing the old pipes with silicone onees for £6. Nice and easy job.

    http://www.vectra-c.com/forum/showthread.php?t=115759
    Last edited by Innes; 3rd March 2011 at 14:42.

  3. #3
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It could also be a faulty Vacuum solenoid but I would have thought that would have left a code.

  4. #4
    Regular Member Signum-Steve's Avatar
    Join Date
    Feb 2009
    Location
    Cramlington Northumberland, V6 Jaguar S-type Sport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar S-Type V6

    Trim : Sport

    Engine : Petrol

    Year : 2003

    Default

    Quote Originally Posted by Innes View Post
    It could also be a faulty Vacuum solenoid but I would have thought that would have left a code.
    could be a small split in the vac pipe causing valve to open and close due to a build up then loss of vaccum repeating itself?

  5. #5
    New Member
    Join Date
    Mar 2011
    Location
    N.Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeah I did put a screw in the end of the vaccum, this just put the car into limp mode, also the vac pipe has been replaced. I checked the electric current in the plug on the vaccum solenoid and it is going up and in the same manor as the butterfly valve moves in and out, so it's an electrical problem?? where does the vaccum solenoid get it's signal from? and why would the signal be going up and down,
    Thanks

  6. #6
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'm not sure. Is it receiving the signal or is it sending the signal? If its sending the signal then the fault may lie in the solenoid? I'm just guessing though.

    Have you checked ALL the vacuum pipes?

    Depending on the age of your 2.2dti it may or may mot have the vacuum reservoir as below (bottom left of image). Worth making sure thats not leaking air as well.


  7. #7
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I saw this in the forum. The response i nthread may help you:

    http://www.vectra-c.com/forum/showth...ight=butterfly

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CDTI 1.9 150 - Major Problems, Help!
    By SamT in forum Engine & Drivetrain
    Replies: 13
    Last Post: 16th February 2011, 15:42
  2. 2.0T Major Problems!
    By cold-chilli in forum Engine & Drivetrain
    Replies: 10
    Last Post: 24th March 2010, 17:45
  3. Windscreen - MAJOR problems
    By RobW in forum Bodywork & Interior
    Replies: 15
    Last Post: 12th November 2009, 01:13
  4. No power after major problems
    By adam3682 in forum Vectra C / Signum Troubleshooting
    Replies: 14
    Last Post: 4th August 2009, 15:16
  5. 2.2DTi idle stutter
    By si_hoss in forum Engine & Drivetrain
    Replies: 1
    Last Post: 19th July 2009, 15:07

Visitors found this page by searching for:

Vectra c solenoid pipes

2.2 dti auto signum throttle clean

vauxhall vectra 2.2 dti vacuum solenoid valve

Vauxhall signum 2.2dti air leak

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •