User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Emissions light help!

  1. #1
    Regular Member LJ sxi-nav's Avatar
    Join Date
    Apr 2007
    Location
    Winchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Emissions light help!

    Hi all, hoping someone can help. As per a couple of recent posts on here I have had to replace the EGR valve. Well the new EGR is fitted and the car is transformed!! Drives a hell of a lot better than it did. The problem is the emissions light is staying on

    summary
    * Loss of power/lumpy running/sooty exhaust etc.
    * In order to drive it last Friday I had to disconnect the EGR, which initially threw up the EML, but the car was much more responsive! When I restarted later that day the EML light was out (as expected it was on at startup, but disappeared as soon as the car was started) but the emissions light was on (Dan_BlackSRi suggested to me this is standard behaviour). I covered approx 60miles with 2 stops, with EGR disconnected.
    * Saturday I set about cleaning the EGR, but didn't do the drilling bit on the solenoid. During cleaning car was disconnected from the battery (I had a new battery to fit anyway, so thought i'd leave it disconnected during the removal, cleaning and refitting). Car was marginally better, but the hesitation was still obvious and emissions light still on. New EGR ordered.
    * This afternoon I fitted the new EGR and standard gaskets. Car is infinitely better, but emissions light still on.

    Any idea what to check next on my 2005(55) 95k 1.9CDTI 8v [120] in order to clear the emissions light - can it be reset by tech2/generic code readers, or is it designed to only be on if there is an actual fault present? Took car on a 15 mile test drive and it drives superb. MPG seems fine (although I know that was a short journey).

  2. #2
    Regular Member LJ sxi-nav's Avatar
    Join Date
    Apr 2007
    Location
    Winchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    bump - drove to work today (~35 miles) and emissions light is still there, but car driving well and mpg is still good (av over 50 miles is 49mpg- mostly A roads and motorway).

  3. #3
    VIP-Member
    Join Date
    Jun 2010
    Location
    `
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    40 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : `

    Trim : `

    Engine : `

    Year : `

    Mileage : `

    Default

    Try disconnecting the battery for half an hour and that may reset the light.
    "We are not some sort of dictatorship!"


  4. #4
    Regular Member LJ sxi-nav's Avatar
    Join Date
    Apr 2007
    Location
    Winchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by DasArab View Post
    Try disconnecting the battery for half an hour and that may reset the light.
    Did that yesterday when the EGR was fitted.


    Anyway it is now SOVLED - After a further 10miles driving the emissions light is now off! guess the ECU just needed an average range of values to work out it is now OK.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Emissions light
    By shuggler in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 16th June 2012, 19:16
  2. emissions light
    By trickster75 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 19th May 2011, 21:10
  3. Emissions Light
    By battle84555 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 20th February 2011, 19:56
  4. Emissions Light
    By Frp01 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 23rd March 2010, 09:31
  5. Emissions Light
    By BigKev1970 in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 7th September 2007, 22:16

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •