User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: heaters not working on signum

  1. #1
    Regular Member
    Join Date
    Feb 2011
    Location
    lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default heaters not working on signum

    hi, ive recently just bought a signum, it has a couple of problems but i got it cheap so got a bit of money to sort it out. the first problem is that the fan heater doesnt work on setting 1, 2, and 3 but it sort of works on number 4 but makes a clicking noise, ive red on here about changing the blue relay, so ive purchased one of these but it made no difference. does anyone have any other ideas to what it could be. thankyou.

  2. #2
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Heater resistor pack and also possibly the heater fan motor if its not working on setting 4.

    Its caused by the drain by the pollen filter being blocked and water coming in through the pollen filter onto the heater fan etc.
    Now I need a turbo to keep up!

  3. #3
    Regular Member
    Join Date
    Feb 2011
    Location
    lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it does work on setting 4 but it makes a clicking noise from the fan i think.

  4. #4
    Regular Member markj23's Avatar
    Join Date
    Aug 2010
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    needs a new motor as its rusted then get down the scrappys they are all the same

  5. #5
    Regular Member
    Join Date
    Feb 2011
    Location
    lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    replaced the resistor pack, the blower now works on settings 1, 2, 3, and 4 but its still making a clicking noise from the blower anyone no how i can stop this without replacing the motor?

  6. #6
    Regular Member markj23's Avatar
    Join Date
    Aug 2010
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what sort of a click? metallic or plastic might need some lube could just be where there is a ridge on shaft where rusted so lube up silicone or wd40 and leave on for a while and see if it goes

  7. #7
    Regular Member
    Join Date
    Feb 2011
    Location
    lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i think its the fan thats clicking it gets faster and a bit louder on each speed.

  8. #8
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you had a look in the fan? probably some damage or something stuck in there.
    Now I need a turbo to keep up!

  9. #9
    Regular Member
    Join Date
    Feb 2011
    Location
    lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    how do i look in the fan? it sounds like the fan is just catching on something slightly if i could see the fan spinning should hopefully see the problem.

  10. #10
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I don't know, maybe take the pollen filter out and have a look? I think you need to do a bit of investigating as its not possible to look over the net
    Now I need a turbo to keep up!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Heaters/Blowers Only Working on No. 5
    By Madison5 in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 14th February 2013, 00:47
  2. Heaters not working
    By MattHD in forum Bodywork & Interior
    Replies: 4
    Last Post: 4th January 2013, 20:07
  3. HELPP!! Heaters not working
    By vectrasri-j in forum Bodywork & Interior
    Replies: 21
    Last Post: 25th December 2011, 21:59
  4. fuel gauge not working signum
    By superjetandy in forum Troubleshooting
    Replies: 2
    Last Post: 28th February 2011, 15:45
  5. Are Signum & Vectra Heaters motors the same?!
    By djr69uk in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 1st September 2008, 17:07

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •