User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Engine Light

  1. #1
    Regular Member Thea-team's Avatar
    Join Date
    May 2006
    Location
    East Riding
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Exclamation Engine Light

    Hi guys,

    I've had a quick search on the forum but not having much joy, Last night the Amber Engine Light on the right hand side of the dash came on and wont budge, i dont have the "car & spanner" light on. Is there any thing i can do to find out what the problem is or is it a trip to the dealers? if so would the Tech2 be covered by the vx warranty?
    BTW its on a '53 2.3 SRi,

    Many thanks
    TheA-team

  2. #2
    Regular Member Maddog1974's Avatar
    Join Date
    Jul 2006
    Location
    Colchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Nothing you can really do yourself these days, needs diagnostic equipment of some sort. Remeber its not just main stealers that have this though. Where i used to work we had a Bosch KTS500 & a Autodiagnos machine which read codes on many vehicles and a bit cheaper if they dont cover it on warranty!

  3. #3
    Regular Member Harry's Avatar
    Join Date
    Aug 2005
    Location
    Uxbridge, London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what does the handbook say? its not the fluid level indicator is it? definitely engine management?

  4. #4
    Regular Member Thea-team's Avatar
    Join Date
    May 2006
    Location
    East Riding
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Not been home since it came on, but will check the handbook when i get in tomorrow. The light is below the fuel level and looks like a small engine.

  5. #5
    Regular Member Thea-team's Avatar
    Join Date
    May 2006
    Location
    East Riding
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just got off the phone from me local dealer and the first thing he said when i mentioned the problem was the most common cause is if the oil level is low..... Checked me oil and its full. Luckily they agreed to book it in on Monday for me. Only problem is they aint got a spare car i can use so ill have to use me wifes old 1.0 Saxo

    Will keep u posted when i get the car back on monday

  6. #6
    Regular Member Harry's Avatar
    Join Date
    Aug 2005
    Location
    Uxbridge, London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hope everything gets sorted for you!!

    have you not got the big black van in the garage with red stripe and grenade throwers?!?!

  7. #7
    Regular Member IamtheStig's Avatar
    Join Date
    Nov 2005
    Location
    Somewhere in time
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like the emissions light so could be something like lamba sensor....

  8. #8
    Regular Member Thea-team's Avatar
    Join Date
    May 2006
    Location
    East Riding
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sod's law when i took the car in yesterday the light went off!, according to the technician there was no faults logged with the system but he has updated the ECU code and said to keep an eye on it....

    Harry, how did u know about me van.... i've since removed the external grenade launchers as the insurance company never had a box to select them so could not offer a suitable insurance policy

  9. #9
    Regular Member Harry's Avatar
    Join Date
    Aug 2005
    Location
    Uxbridge, London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    that's a shame!

  10. #10
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Thea-team
    Sod's law when i took the car in yesterday the light went off!, according to the technician there was no faults logged with the system but he has updated the ECU code and said to keep an eye on it....

    If the lights been on, a fault code MUST have been logged.. strange why they couldn't retreive it??

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Replies: 17
    Last Post: 16th August 2012, 10:07
  3. Engine and Spanner Light Before I Start The Engine
    By corderz in forum Engine & Drivetrain
    Replies: 14
    Last Post: 24th March 2011, 18:48
  4. No throttle, traction control light, engine management light
    By si260188 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 9th May 2010, 21:45
  5. Replies: 3
    Last Post: 28th April 2009, 19:49

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •