User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Vectra cdti battery/alternator problem help

  1. #1
    Regular Member
    Join Date
    Mar 2007
    Location
    S Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra cdti battery/alternator problem help

    2 days ago battery light started coming on about 3 min after starting the car. Yesterday the abs light came on for few seconds then the power steering failed so pulled over and stopped. Car wouldn't restart due to batterybeing dead.

    So I got towed home jump started the car and it started. So over night I charged the battery and it measured 12.8v on the meter. I started the car and it dropped down to 11.8v and drops further as u load it up with lights being turned on.
    I'm measuring 12v off the alternator is this right?

    The belt seems ok on the alternator has anyone got any suggestions to confirm what's the problem?

    Car is 56 plate vectra 1.9cdti 150

  2. #2
    Regular Member Mopar Man's Avatar
    Join Date
    Jan 2011
    Location
    herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Alternater should be putting out 14.5.

  3. #3
    Regular Member
    Join Date
    Mar 2007
    Location
    S Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Do u think it's the alternator or is there something else in the system that can be the problem?

    Anyone know how to change alternator if it is ******ed?

  4. #4
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    I'd expect around 13.5v at idle and about 14.5v at around 1000rpm, so I'd be thinking about a possibly dying alternator. Might be worth finding a decent local auto-electrician to confirm it for you and possibly replace if you don't fancy doing it yourself.

  5. #5
    Regular Member Mopar Man's Avatar
    Join Date
    Jan 2011
    Location
    herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    There is a how to on here.
    Common problem.

  6. #6
    Regular Member Mr Hyde's Avatar
    Join Date
    Feb 2011
    Location
    Suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Alternators seem to be a throw away part on these cars. My guess is yours is cooked too

  7. #7
    Regular Member Mopar Man's Avatar
    Join Date
    Jan 2011
    Location
    herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Mr Hyde View Post
    Alternators seem to be a throw away part on these cars. My guess is yours is cooked too
    Have had the regulaters changed in my alternaters, on my old 120 and 150.

  8. #8
    New Member
    Join Date
    Feb 2011
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I use my Vectra as a Private Hire Vehicle. Last night my light on my taxi set started to flicker so i pulled up and turned the engine off and it wouldnt start.
    I managed to get a Jump to drive home and on doing so steering was EXTREMELY heavy at times, ABS light coming on and off and dash lights acting very strange.
    Had Green Flag out this morning and they said its 100 % the Alternator as power steering wasnt working etc.

    Gutted my car has done 70,000 miles and everything seems to be going wrong at the moment.

    My car is also 2007 CDTi

  9. #9
    Regular Member
    Join Date
    Mar 2007
    Location
    S Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    That's the same as mine also gutted iv only got to 60k miles!
    Anyone had experience of reconditioned alternators or is it better to geta new one? Any suggestions on best place to get one and what's the damage?

  10. #10
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    Nearly new smashers yard!, the 120 & 150 are the same unit.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Alternator/Battery problem query....
    By Tony W in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 30th January 2013, 19:09
  2. Vectra 1.9 CDTi 150 Alternator / battery voltage
    By trucklord in forum Electrical & ICE (including SatNav)
    Replies: 17
    Last Post: 11th October 2012, 10:06
  3. Alternator or Battery Problem?
    By bu_zz2020 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 1st April 2012, 20:03
  4. Power Steering or Battery/Alternator problem ???
    By kizalini in forum Engine & Drivetrain
    Replies: 7
    Last Post: 23rd November 2009, 00:50
  5. 05 cdti (120) alternator and battery swap?
    By longtings in forum Engine & Drivetrain
    Replies: 1
    Last Post: 16th June 2009, 16:27

Visitors found this page by searching for:

https:www.vectra-c.comforumshowthread.php130944-Vectra-cdti-battery-alternator-problem-help

2007 vectra 1.9 cdti alternator problems

astra sri 150 recon alternator north west

vectra power steering and battery problems

1.9 cdti faulty alternator issues

vectra c alternator symptoms

vauxhall vectra alternator problems

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •