User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Replacement injectors - hard to start?

  1. #1
    Regular Member mozzer99's Avatar
    Join Date
    Jun 2010
    Location
    bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Replacement injectors - hard to start?

    My CDTI 150 was running poorly when cold and very lumpy tickover, but starting instantly.
    3rd injector wring has been replaced a while ago. EGR is almost new and tests out OK on opcom.
    One fuel injector was way out of spec (deviation over 5.0). Others were at top end of acceptable (2.4 -3).
    Obtained a replacement set of used injectors on Ebay and fitted them today (coded them in to the ECU).

    Took a while to start, but as the feed pipes had been disconnected no surprise there. All injectors gave a reading around 1.0 and the engine runs smoothly.
    However even after a run it now takes a good 5-6 seconds of spinning over to gradually catch and fire up when starting.

    Any ideas please?

  2. #2
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    Air getting into the fuel lines perhaps via the injectors?

  3. #3
    Regular Member mozzer99's Avatar
    Join Date
    Jun 2010
    Location
    bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for your advice. After 100 miles it now starts as usual. Quite why it takes so long to 'purge' I can't imagine?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. hard to start
    By bobbleheadbarney in forum Vectra C / Signum Troubleshooting
    Replies: 17
    Last Post: 23rd May 2012, 13:29
  2. Injectors replacement
    By deeks08 in forum Vectra C / Signum Troubleshooting
    Replies: 7
    Last Post: 26th October 2010, 22:28
  3. Replacement injectors bought ££££
    By Celes in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 22nd August 2009, 00:17
  4. hard to start
    By andrew m in forum Engine & Drivetrain
    Replies: 3
    Last Post: 21st October 2008, 20:30
  5. hard to start
    By Pouge in forum Vectra C / Signum Troubleshooting
    Replies: 10
    Last Post: 4th August 2006, 03:37

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •