User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: battery light on along with spanner through car light

  1. #1
    Regular Member
    Join Date
    Jan 2009
    Location
    liverpool
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default battery light on along with spanner through car light

    hi all.
    ok yet another problem.yesterday the battery light came on along with
    the spanner through the car light on the tacho.am right in thinking the alternators kaput ? guess i should be getting the battery and alty tested,just thought i ask to see if there may be another issue someone knows of. cheers in advance.

  2. #2
    Regular Member john_k_sri's Avatar
    Join Date
    Oct 2006
    Location
    Waterloo, Liverpool
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Had the same last Tuesday and it was the alternator.

  3. #3
    Full Member superstuper's Avatar
    Join Date
    Dec 2006
    Location
    Trieste, Italy
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Confirm. Same on mine this summer.

  4. #4
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    as above my alt died a month ago, driving with no power is no fun lol...

  5. #5
    Regular Member
    Join Date
    Jan 2009
    Location
    liverpool
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    had the battery tested and surprise surprise there's no charge going in.looks like a new alternator then

    also when yours did the same did your revs rise? mines now
    ticking over at 1k revs constantly.

  6. #6
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    yes revs do rise,get it done asap, you will lose power steering & all electrics very soon if not already...
    my new alt was £300 all in for the cdti 16v

  7. #7
    Regular Member
    Join Date
    Aug 2008
    Location
    Manchester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I had that with my alternator last week. Lost all power steering, it was like multiple engine failure.

    It cost £468 including VAT as I also needed a new battery but they had to take out the drive shaft. I have a 1.9CDTi SRI 150 Estate 56 Reg.

  8. #8
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    why remove drive shaft?

  9. #9
    Regular Member
    Join Date
    Aug 2008
    Location
    Manchester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    The said it was becasue of where the alternator was, it was difficult to get at. They had it 3 days, £180 for the alt, £100 battery, £90 labour, £20 pulley and then VAT.

  10. #10
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Jeez they clearly don't know what they're doing...
    have a look at this how to
    http://www.vectra-c.com/forum/showthread.php?t=92987

    mine was done the same afternoon

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. spanner and battery light on
    By honyin in forum Troubleshooting
    Replies: 9
    Last Post: 8th July 2012, 17:38
  2. Battery & Spanner Light on.
    By ickleric in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 11th September 2011, 21:31
  3. Battery light and car with spanner icon?
    By johnnyallen in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 22nd June 2010, 10:29
  4. Help..Clear spanner light by disconnecting battery?
    By marky2027 in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 23rd April 2010, 13:01
  5. Spanner light after changing battery
    By gtr1000 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 10th December 2008, 21:40

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •