User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Vectra c 1.9cdti (dead not turning/cranking)

  1. #1
    Regular Member
    Join Date
    Feb 2011
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra c 1.9cdti (dead not turning/cranking)

    Hi everyone I need your advice please. I work in a body shop so we have dealings with insurance cars that come in after total loss. I usually only go for astras but when this car came in I thought why not. It looked simple enough light front end damage rads, front bumper and lights a straight forward repair.this is where I hit a snag, since I had the car it's never started, but I thought this was to do with the crash, I am now learning that it's not. I have replaced the dash, rads, etc, but the car still isn't cranking when I turn it over. All lights on the dash are off apart from the glow plugs, and the battery light and all other electrics are working in the car so we can rule out battery problems, the plugs are ok and there is diesel in the car. I have had 2 diagnostic men 1 couldn't communicate at all with the ECM and the second one managed to communicate through the instrument panel however his machine could not recognise the ECM. It did clear faults in the cim and and the bcm but it still made no difference as to what the problem is. I have now been informed that following a crash these cars have some kind of cut off switch and the car has effectively gone to sleep ie the main ecu is not communicating with the ecu's hence the car not starting.
    I am just wondering if anyone else has had experience of this as I am scratching my head, or knows anything about it.

  2. #2
    Regular Member
    Join Date
    Feb 2011
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Anyone ?

  3. #3
    Regular Member
    Join Date
    Jan 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    loads of cars have a fuel reset button mate , find it , press it and see what happens ??

  4. #4
    Regular Member
    Join Date
    Feb 2011
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks 4 the input mate but I can seem to find any info
    On where it might b anywhere
    In fact from what I can gather these veccy's don't have
    The inertia switch that's why I was asking

  5. #5
    Regular Member LADmachining's Avatar
    Join Date
    Feb 2010
    Location
    Hampshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I haven't ever heard of there being an inertia switch on a Vauxhall (worked on them since 1995).

    If there was, on other makes (Rover/Ford spring to mind) they used to be wired in to the fuel pump circuit, so would cut power to the pump but still allow the ECU to power up.

    Have you checked all of the fuses in the underhood module are present and intact? are all of the earths connected and secure?

    Has the engine ECU been damaged in the accident (it is mounted behind the front bumper - drivers side). This could explain why it is not responding when interrogated by the diagnostics tester.

  6. #6
    Regular Member
    Join Date
    Feb 2011
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks LADmachining
    I wondered why I had never heard of it
    I have checked all the fuses and relays under the bonnet
    I've also had a real good look @ the ecu it looks fine
    Ie there is no visible damage all wires and plugs intact
    The damage was on the front but it was the middle
    Enough 4 me not 2 have 2 change the wings
    How fragile r they ? I mean if dropped it would it b broken ?
    Just it looks pretty robust lol

  7. #7
    Regular Member LADmachining's Avatar
    Join Date
    Feb 2010
    Location
    Hampshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    They are quite solid, and would need a fair knock to cause damage. Saying that, the accident the car had could have put the wrong sort of impact through the ECU that caused internal damage. Sod's law says it has.

    First check, as you say the ECU is visually OK, is for power and earth at the ECU, and also the continuity of the CANbus wiring to it.

  8. #8
    Regular Member deano1's Avatar
    Join Date
    Jan 2007
    Location
    leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra estate

    Trim : Sri xp2

    Engine : 1.9 cdti 150

    Year : 2008

    Mileage : 100000

    Default

    hi ive repaired quite a few vectras never had ecus go with out being hit what engine is in the car have you removed any earth straps is sarter motor good ? have you tried spare key incase its a immobilizer prob.

  9. #9
    Regular Member
    Join Date
    Feb 2011
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanx for all the input guys
    I've finally got it sorted lol
    There is a broken earth wire to pin 85 in the fuse Box under the bonnet
    Pin 85 is the earth pin to the red ecu relay
    Hence no power to the ecu
    All the electrics worked part from the dials
    But the car would not crank although the relays would click
    I sent the ecu away thinking it could b faulty and it came back clean
    But I still couldn't get the ecu to communicate
    So after many hours of searching for a broken wire lol
    I decided to check every pin in the fuse box with a power probe
    And as if by magic I stumbled on pin 85 and nothing checked if it was
    Ment to b an earth or live. Stuck a piece of wire down the pin plugged up the relay
    Then joined the other end to the battery
    And after much chugging to my amasement it started woooooohooooo lol

  10. #10
    Regular Member daveypower's Avatar
    Join Date
    Mar 2011
    Location
    Donegal
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    class man, least you stuck with it, fair playlol

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9cdti farts 10s after turning off
    By Craig1985 in forum Engine & Drivetrain
    Replies: 14
    Last Post: 18th February 2013, 11:25
  2. 120 cdti cold start cranking
    By Slammedorion in forum Engine & Drivetrain
    Replies: 19
    Last Post: 18th January 2013, 13:15
  3. 1.9cdti Cambelt Change - 'Top Dead Centre' Question...
    By snapsnap in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 22nd May 2012, 16:37
  4. Manual cranking
    By signum_rob in forum Engine & Drivetrain
    Replies: 6
    Last Post: 10th November 2011, 11:29
  5. Vectra not turning over?!!?!?!
    By djbasics123 in forum Vectra C / Signum Troubleshooting
    Replies: 20
    Last Post: 13th October 2007, 14:23

Visitors found this page by searching for:

https:www.vectra-c.comforumshowthread.php130643-Vectra-c-1-9cdti-(dead-not-turning-cranking)

vectra c not cranking wellvectra 1.9 cdti no turning overvectra 1.9 cdti not crankingvectra 1.9 cdti not turning overvectra cdti no turn

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •