User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: CDTi 150 - Loss of Power upto 2500rpm?

  1. #1
    New Member
    Join Date
    Feb 2011
    Location
    Bracknell
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default CDTi 150 - Loss of Power upto 2500rpm?

    Hi,
    my Vectra is struggling to start in this cold weather and once I get it going, it refuses to rev until it's warmed up a little. Even then it's slow to to raise the revs. Then it REALLY struggles around the 2000-3000rpm mark. After that the turbo kicks in and it's fine above the 3000 mark.

    The engine management light isn't on and it's only happened a few times. The first over a year ago when we again had the cold weather.

    Does anyone know if this is related to the manifold problem that a lot of people discuss here or could it be something to do with the airflow or EGR?

    Thanx

  2. #2
    Regular Member neill's Avatar
    Join Date
    Nov 2009
    Location
    Warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : Z19DTH

    Year : 2004

    Mileage : 172000

    Default

    im having the same problem pal, when your power eventually kicks in does it pin you back all of a sudden?

  3. #3
    Regular Member corderz's Avatar
    Join Date
    Mar 2010
    Location
    Bradford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like the inlet manifold 2 me

  4. #4
    Regular Member
    Join Date
    Jan 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    as above or EGR ? had a signum in that had had all sorts done inc manifold but the EGR was the culprit and again no EML or fault codes ! i'd recommend EGR renewal first to rule it out completely but its up to you

  5. #5
    Regular Member F33F33's Avatar
    Join Date
    Nov 2009
    Location
    Preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRi VX-Line RED

    Engine : 2.0CDTi

    Year : 2012

    Default

    Hmmm i'm getting the same problem but wasn't due to the cold weather as it was fine in dec / jan. Getting my inlet and gasket fitted Friday and if that doesn't fix it, new EGR.

  6. #6
    Regular Member nutron's Avatar
    Join Date
    Jul 2005
    Location
    South Central England
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : very

    Engine : Z19DTH

    Year : Nosey

    Default

    EGR, Swirl Valves, VNT vacuum control line leak or sticking VNT vanes.

  7. #7
    Regular Member sloper's Avatar
    Join Date
    Oct 2010
    Location
    bradford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    your boost sensor maybe in need of a clean also, easy to do.

    You can do a test to see if its your egr, make a blanking plate from a thin piece of tin and put it between the egr and inlet manfold. If the powers back you know your egr needs a clean or you need to replace it. Your spanner light or EML will come on but dont worry itl soon clear after you remove the blanking plate

  8. #8
    New Member
    Join Date
    Feb 2011
    Location
    Bracknell
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I've been looking around the forum for ideas. The manifold problem comes up quite often but what struck me was that most people mention that the linkage arm is loose or has come off. Mine is still fixed, there is some play but very little. Also, the third pod from left is a bit sooty, the others appear clean. Any more ideas?


    Thanx

  9. #9
    Regular Member
    Join Date
    Apr 2007
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : CDTI 150

    Trim : Design

    Engine : Z19DTH

    Year : 2005

    Default

    In most cases the culprit will be the EGR.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 150 CDTi power loss
    By rockafella8587 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 15th December 2011, 12:48
  2. 1.9 cdti loss of power
    By mark1484 in forum Vectra C / Signum Troubleshooting
    Replies: 16
    Last Post: 8th July 2011, 08:12
  3. Loss Of Power On 3.0 cdti sri - please help
    By L.Hamilton in forum Engine & Drivetrain
    Replies: 7
    Last Post: 14th June 2011, 18:00
  4. 1.9 CDTI 150 loss of power
    By Nick_206_180 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 22nd January 2009, 20:57
  5. loss of power 150 cdti
    By SRI-150 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 17th May 2008, 14:24

Visitors found this page by searching for:

z19dth sticking vnt

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •