User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Rear door electrics

  1. #1
    Regular Member
    Join Date
    Jul 2008
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Rear door electrics

    Hi,

    I have searched but couldn't find a similar problem so here goes. On my pre facelift Vectra the red light on the door when you open it will no longer comes on and also when the door is open it does not register on the dashboard. I have no idea where to start to find the problem so any advice would be appreciated.

    Another thing I have noticed is that the interior alarm sensors don't work when I lock the car the LED just flashes, Don't know if this would be related.

    PS its the rear door on the drivers side.

    Thank you

    John

  2. #2
    Regular Member si_hoss's Avatar
    Join Date
    Apr 2009
    Location
    Stevenage, Herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Does the interior light come on? I would say it sounds like the switch on that door is stuck, not sure where it is actually as never looked. If you find it give it some WD-40 and a good loosening up!

  3. #3
    Regular Member
    Join Date
    Jul 2008
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi, thanks for the quick reply.

    The interior light does not come on when that door is open. I will have a look around the door to see if I can find a switch.

    Cheers

  4. #4
    Ex Vec-C Admin Ian-Highlander's Avatar
    Join Date
    Jun 2008
    Location
    Ely, Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    61 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Tourer

    Trim : Elite

    Engine : 2.0 CDTI (160ps)

    Year : 2010

    Default

    The switch is built into the lock mechanism on Vec-C's. It will probably need the lock mechanism changing/replacing on that door.
    "Doing a good job here is like wetting your pants in a dark suit, you get a warm feeling but nobody else notices"
    Maptun Tuned 2.0T Estate - click HERE for mods list.
    Brentwood 2012: Winner, Saturday Show. Hull 2012: Winner, Best Estate. Hull 2013: Winner, Best Estate & Runner Up, Best I.C.E

    Now Gone, bring on the Insignia (now "Teapot" Tuned)...

  5. #5
    Regular Member
    Join Date
    Jul 2008
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks for the reply,

    do you know if its a big job?

  6. #6
    Ex Vec-C Admin Ian-Highlander's Avatar
    Join Date
    Jun 2008
    Location
    Ely, Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    61 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Tourer

    Trim : Elite

    Engine : 2.0 CDTI (160ps)

    Year : 2010

    Default

    Not the easiest job in the world, but not too terrible.
    "Doing a good job here is like wetting your pants in a dark suit, you get a warm feeling but nobody else notices"
    Maptun Tuned 2.0T Estate - click HERE for mods list.
    Brentwood 2012: Winner, Saturday Show. Hull 2012: Winner, Best Estate. Hull 2013: Winner, Best Estate & Runner Up, Best I.C.E

    Now Gone, bring on the Insignia (now "Teapot" Tuned)...

  7. #7
    Regular Member ChrisBilly's Avatar
    Join Date
    Jul 2009
    Location
    The Rift, Cardiff
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Try re-seating the large blue plug between the door and pillar.

  8. #8
    Regular Member si_hoss's Avatar
    Join Date
    Apr 2009
    Location
    Stevenage, Herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My Golf Mk4 had a similar problem, the central locking was playing up and the light wouldn't come on on the one door. I looked into it and the common fix was to re-solder the joints on the microswitches in the lock setup. Not saying the Vec has the same setup, but if that kinda thing works would cost nothing compared to a new locking mech.

  9. #9
    Regular Member
    Join Date
    Jul 2008
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks for all your advise, I have this afternoon off so I will have a good look at it

  10. #10
    Full Member paul.sessions's Avatar
    Join Date
    May 2009
    Location
    leighton buzzard
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i took one off a spare door i had the other day to find out (i had the same prob). i wanted to see how it worked i wrecked the lock mechanism trying to open it but there is a tiny microswitch inside the sealed unit, so i tried triflow similar to wd40 in the car door that was playing up it worked for a few days then came back on. so then i sprayed switch cleaner into the lock about half a can. and its been off a couple of weeks so far. fingers crossed! it stays that way. spray into the lock at 45 degrees downwards thats where abouts the switch is situated..

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. drivers door electrics dead!
    By pugs,signum in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 27th January 2012, 14:47
  2. Passenger door window and mirror electrics not working. Any ideas, thanks.
    By MT82LFC in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 7th May 2011, 01:09
  3. Rear Electrics
    By steve in forum Electrical & ICE (including SatNav)
    Replies: 13
    Last Post: 5th March 2011, 16:27
  4. Drivers door electrics playing up
    By hefilump in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 12th April 2010, 12:52
  5. rear electrics
    By scottyd in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 21st April 2009, 18:45

Visitors found this page by searching for:

vectra c rear door micro switch

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •