User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: Injector Pump

  1. #1
    Regular Member efcmandan's Avatar
    Join Date
    Aug 2006
    Location
    North-West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Injector Pump

    Hi all

    Well, I've had my 52-plate 2.0DTi Elegance for just over a month and done over 2000 miles without a problem. Until this morning...

    Driving along, car starts chugging and eventually conks out with the spanner/car icon on the dashboard. To cut a long story short, RAC recovered the car (£102) to the local main dealer where the car has been all day. Dealer initially said the first diagnostic was £70, and that sometimes things are easily fixed within that first diagnostic.

    Not this time though. Apparently I need a new injector pump, which is going to cost me £2,400 including all parts and labour. Needless to say this has made me feel a little bit ill, especially as the car only cost me £4000.

    A few questions I would be grateful for an answer to:

    Anyone got a spare injector pump?
    Anyone know a decent non-dealer garage in the north-west (Warrington)?
    Is this a common thing to happen?

    I'm wondering if I have any comeback on the guy I bought it from, as he was a trader. Though the receipt clearly said 'sold as seen' and 'no warranty', I'm sure there's some protection for plebs like me.

    Any words of advice greatly appreciated, and pity is nice too.

  2. #2
    Regular Member Braggy's Avatar
    Join Date
    Jun 2006
    Location
    St Helens
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    you think you have problems mines with plp in Warrington also

    It's a '53 plate 2.2 DTi SRi with 22,00 miles genuine with loss of power at high revs and so far it has now had and in this order:
    ecu software update
    air mass meter
    egr valve
    vac pipes
    four injectors and injector pipes
    fuel pump
    and now a turbo!!!!!!!!!
    guess what ............is its still got the same problem!!!!
    so a field engineer from vauxhall is now to look at the car on friday 15/09/06
    I have owned the car for thirteen weeks of which it has been at the dealer now for six weeks!

    thank god its under warranty until oct 06!

    you could try dieselcraft in widnes they do recon stuff

  3. #3
    Regular Member efcmandan's Avatar
    Join Date
    Aug 2006
    Location
    North-West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Jeez Braggy, that sounds like a nightmare. I hope they've given you a courtesy car, and make sure you get some free servicing off them when you eventually get the car back! Not that you probably want to take it back there, eh?

    I've just looked up Dieselcraft and will buzz them tomorrow, thanks for that.

  4. #4
    Regular Member Caterman's Avatar
    Join Date
    Aug 2005
    Location
    Here, there and every where!
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Had my pump replaced 2 weeks ago (under warranty) and i thought that was expensive at £1660.
    You might be better off ringing around specialist diesel pump repairers to see what they can do for you m8.

  5. #5
    Regular Member efcmandan's Avatar
    Join Date
    Aug 2006
    Location
    North-West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Caterman, thanks for the info. I've resigned myself to the fact that I'm going to lose lots of money very soon

  6. #6
    Regular Member Braggy's Avatar
    Join Date
    Jun 2006
    Location
    St Helens
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by efcmandan
    Jeez Braggy, that sounds like a nightmare. I hope they've given you a courtesy car, and make sure you get some free servicing off them when you eventually get the car back! Not that you probably want to take it back there, eh?

    I've just looked up Dieselcraft and will buzz them tomorrow, thanks for that.
    They have given me a Vectra Design 1.8 with 2500miles on it, not very impressed it would n't pull you out off bed!

    as regards free service I think I would prefer a free warranty in the long run!

  7. #7
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    this is myn on the ebay .........................


    http://cgi.ebay.co.uk/ws/eBayISAPI.d...tem=4634379577


    you need to check the codes on the side of the pump match 100%

  8. #8
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Braggy
    you think you have problems mines with plp in Warrington also

    It's a '53 plate 2.2 DTi SRi with 22,00 miles genuine with loss of power at high revs and so far it has now had and in this order:
    ecu software update
    air mass meter
    egr valve
    vac pipes
    four injectors and injector pipes
    fuel pump
    and now a turbo!!!!!!!!!
    guess what ............is its still got the same problem!!!!
    so a field engineer from vauxhall is now to look at the car on friday 15/09/06
    I have owned the car for thirteen weeks of which it has been at the dealer now for six weeks!

    thank god its under warranty until oct 06!

    you could try dieselcraft in widnes they do recon stuff
    have they checked the turbo air hose from the inter cooler to the inlet manifold on the under side they seem to be splitting .....

  9. #9
    Regular Member efcmandan's Avatar
    Join Date
    Aug 2006
    Location
    North-West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi Benny

    not sure what they've checked and what they haven't. I paid them £83 to diagnose it, and they told me I needed a new injector pump. I like the look of yours on Ebay, but it probably won't fit my 52-plater. I'm gonna get the numbers of the pump tonight and get back to you.

    Cheers

  10. #10
    Regular Member solorider's Avatar
    Join Date
    Sep 2006
    Location
    swindon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    im afraid the pump on ebay wont be any good to you.the pump on a vectra c is unique to the vectra c,and it has to be the same engine size ie 2.0 for 2.0

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. injector pump leak
    By conmacirl22 in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 15th February 2012, 18:57
  2. 20 dti injector pump problem
    By stevie b in forum Engine & Drivetrain
    Replies: 6
    Last Post: 20th March 2009, 20:55
  3. 2. Dti Injector pump
    By wilf2312 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 4th December 2007, 12:59

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •