User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: EGR replaced - not much power

  1. #1
    Regular Member
    Join Date
    Jan 2011
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused EGR replaced - not much power

    Hi guys,

    was wondering if anyone could shed some light on this.
    Bought my car from non VX dealer. Its 07 1.9CDTi automatic with 86k miles on the clock.

    After poor performance and 38mpg the dealer kindly offered to replace the EGR valve today.
    Now I seem to feel that the turbo kick in isnt as much kick in as it used to be ...
    In order to get power out of it, i really have to push the pedal down ....
    No warning lights.

    What could it be ... this time?

  2. #2
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    If it's only done it since the EGR was changed by the dealer, could be a faulty part?? Pay them another visit to get it checked out

  3. #3
    Regular Member
    Join Date
    Jan 2011
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by tony-1977 View Post
    If it's only done it since the EGR was changed by the dealer, could be a faulty part?? Pay them another visit to get it checked out

    Well ... I dont think they like me there as it is ;o)
    The crankshaft sensor had to be changed within a week, not I requested the EGR to be changed

    Is there anything that needs to be reset or anything after fitting a new EGR? I remember that I had to reset the car when I changed to a K&N air filter .....

  4. #4
    Regular Member
    Join Date
    Jan 2011
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    OK, drove the car to work today and it appears that I have a nice long flat spot between 0-3000 revs ... then it kicks in ...
    Before I had to get to 1500 - 2000 before it kicked in ...

    Any ideas????

  5. #5
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    check the swirl bar is still in place

  6. #6
    Regular Member
    Join Date
    Jan 2011
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Exclamation

    Right boys ... take that!


    as I said, I had the EGR valve replaced yesterday as my mpg was a joke as well as low revs. When picking it up, it didnt feel the same as it did when I dropped it off, so thought the ECU needs adjusting. Also smelled diesel everytime I drove ;o(

    Cruise control lost speed when the car went uphill, to get it to 70 I had to push the pedal through the floor ...
    After hardly enough power to go anywhere on my way home tonight, I ended up driving down a quiet road with a hedge on my right. Had the window open and everytime I accelerated I heard a lot of air noise from the engine. Thought it was my K&N sucking like hell, but then noticed it sounded more like blowing ...

    So stopped and checked .... since they changed the EGR that was my first call

    I noticed that there was a gap to the pipe going out at the bottom of it. So played with the 2 screws on the top and I could turn both of them with my finger
    So tightened them up and presto ..... full accleration back right from the word go .... and 53mpg for the rest of the trip ...
    In fact it looked like they where never screwed in properly from the word go. Mechanice must have simply forgotten to do it ....

    I was furious after that experience. Was already booked in for a full VX dealer test on Saturday and was prepared to pay for it - just to get it sorted.
    But now I have a nice, powerfull car and I am veeeeeeeeeeeeeeeeeeeeery happy

    The moral is: DONT TRUST A MECHANIC ... USE COMMON SENSE !!!!!
    Last edited by Vectrarmand; 22nd February 2011 at 23:49.

  7. #7
    Regular Member neill's Avatar
    Join Date
    Nov 2009
    Location
    Warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : Z19DTH

    Year : 2004

    Mileage : 172000

    Default

    happy to hear you sorted your problem, wish mine as as simple

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What do I need replaced
    By m20_swe in forum Engine & Drivetrain
    Replies: 8
    Last Post: 25th March 2012, 08:45
  2. any one replaced the ecu?
    By twaiter in forum Electrical & ICE (including SatNav)
    Replies: 62
    Last Post: 13th January 2011, 23:44
  3. maf replaced still need help
    By scutster in forum Engine & Drivetrain
    Replies: 15
    Last Post: 15th May 2010, 10:16
  4. DMF + Clutch replaced, now loss of power
    By yzf1kr in forum Engine & Drivetrain
    Replies: 0
    Last Post: 28th July 2009, 21:07
  5. Alternator replaced
    By woodaj in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 18th June 2009, 14:49

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •