User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: 2.2 dti Turbo problem

  1. #1
    New Member
    Join Date
    Jan 2011
    Location
    West Yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default 2.2 dti Turbo problem

    Hi Guys, hopefully somebody can point me in the right place, My turbo started whistling really loud under load, and now just recently its whistling even on tick over? I have check the obvious pipes seem ok, got somebody to rev it so i could listen, and the noise is coming from the turbo.
    Could it be a gaskett or more likely the turbo.
    Sorry its Vec C 2.2 dti. its had a turbo on just over a year ago so out of warranty now.

  2. #2
    North Wales - Assistant Regional Organiser
    Join Date
    Feb 2010
    Location
    Wirral
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Strange with it being a new turbo. Is there any play in the shaft? Take the rubber pipe off that goes into the turbo and you should see the blades on the compressor. WITH THE ENGINE OFF (don't want fingers to be lost!) give the shaft a gentle wiggle and see if there's any play in it. Side to side and front to back.

  3. #3
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Did you take the plastic cover off first? I tired pin pointing the whistle and it sounded like it was coming from the turbo but when I took the cover off it turned out to be a split intercooler hose at the front. The cover was redirecting the air and sound towards the turbo! Remember to give the inter cooler hoses a squeeze to open up and cracks in them otherwise they are hard to spot. They tend to go on or near the corners.

    You probably know where everything is but thought i'd post this pic up to help :-)


  4. #4
    New Member
    Join Date
    Jan 2011
    Location
    West Yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks, for that will have a proper look at weekend, Did you find it was using more diesel because of the split hose as well?

  5. #5
    Regular Member Signum-Steve's Avatar
    Join Date
    Feb 2009
    Location
    Cramlington Northumberland, V6 Jaguar S-type Sport
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Shortland78 View Post
    Thanks, for that will have a proper look at weekend, Did you find it was using more diesel because of the split hose as well?
    If your MPG has dropped then it sounds like a split in the intercooler pipe. Are you producing more black smoke than the norm?

  6. #6
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    My MPG had been crap anyway but I think it was down to needing a good service as the MPG was still poo after I had replaced the hose. Now had it serviced which included and engine flush and now getting 42mpg instead of 31mpg!!

    I only noticed the split when it sounded like an angry snake under the hood when I put my foot down. I didn't notice any black smoke (and its always run clean - no smoke at all) but when my home made hose popped off recently it smoked heavily. Upgraded my weak jubilee clip with a T-Bolt Clip and it hasn't popped off since.

  7. #7
    New Member
    Join Date
    Jan 2011
    Location
    West Yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks for the advice, will change the hose and give her a service, will keep you posted if it cures her or not

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.0 Turbo problem
    By the stig in forum Engine & Drivetrain
    Replies: 7
    Last Post: 4th March 2010, 20:31
  2. Turbo Problem
    By sberrow in forum Vectra C / Signum Car Chat
    Replies: 20
    Last Post: 12th March 2009, 21:01
  3. problem with turbo or ?
    By chikenbud in forum Engine & Drivetrain
    Replies: 3
    Last Post: 1st February 2009, 16:03
  4. Turbo Problem...
    By dankidd in forum Engine & Drivetrain
    Replies: 3
    Last Post: 11th August 2008, 22:55
  5. 2.0 DTI turbo problem
    By Vibez_Uk in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 19th March 2008, 21:15

Visitors found this page by searching for:

vectra dti turbo.fault

vectra dti turbo problem

vauxhall vectra 2.2 dti turbo problems

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •