User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Flaming P0100 Error again

  1. #1
    Regular Member
    Join Date
    Aug 2010
    Location
    Blackwood
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Flaming P0100 Error again

    Hi all,

    had the problem light come on the dash, goes out when switch the engine off then back on. now the engine management light stays on constantly.
    RAC came out, cleared the error & told me its to do with the mass air flow & its malfunctioned.
    he cleared the error and all was fine. 2 days later its back again.
    i dont want to book the car into a garage for them to charge me to look at it & do the same as the rac man.
    can anyone offer me any assistance where to start looking bearing in mind i know very little about the engines.

    thanks to anybody that can offer help to a very desparate man

  2. #2
    Regular Member
    Join Date
    Jun 2009
    Location
    Dover
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Best thing to do is find someone with the same engine and swap Mass Air Flow to see if this work P0100 stands for MAF fault

  3. #3
    Regular Member
    Join Date
    Aug 2010
    Location
    Blackwood
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks for replying. does it have to be the same engine size aslong as its a diesel?
    ive taken the maf senso off (assuming its the small 4inch fat pipe coming from the air filter box) off & blew through it. also blew the small plug that i had to disconnect from the fat pipe incase of dirt in the connections.
    also checked the air filter but its as clean as a whistle.
    disconnected the battery to see if that cleared the light no joy.
    ive also checked a smal 2inch fat pipe coming from the engine block at the back to the tubo (held on by 2 jubille rings), coudlnt get it off so squeezed it & felt all around no cracks (im assuming this is the turbo pipe or boost pipe or summit)
    sorry bout all the assumings but ive taken off what i could easily remove with a socket set & put back on.

  4. #4
    Regular Member
    Join Date
    Aug 2010
    Location
    Blackwood
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I've paid 35 quid to have a garage hook the car up to see if its showin the fault and its stil p0100. They quoyed me 250 quid to fix but couldn't guarantee that that will fix it. I've been quoted 50 quid for just the sesor insert or 100 for the whole part. Is this any good or too dear? I'd rather lose 50 and find out that its not the maf sensor than lose 250 and let the garage rip me off again to try something else.

  5. #5
    Regular Member
    Join Date
    Apr 2007
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : CDTI 150

    Trim : Design

    Engine : Z19DTH

    Year : 2005

    Default

    Go to a garage that will guarantee a fix.
    There's nothing more that annoys me than garages who change stuff dont cure the fault and charge. I dont and I charge a fraction of what garages do.
    I know some folk malign the Halfords Autocentres (previously Nationwide) but whilst they charge £50 for a diagnostic they will give a full refund if their diagnostic is not correct, its part of the company policy.
    The one near me is very good.

  6. #6
    Regular Member
    Join Date
    Jun 2010
    Location
    north east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    In your case id be tempted to invest in one of these

    http://cgi.ebay.co.uk/AUTEL-MAXISCAN...item3a62821667

    As i understand it you can have it connected and record the maf sensor flow.

  7. #7
    Regular Member
    Join Date
    Aug 2010
    Location
    Blackwood
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I've got a brand new maf sensor comin for 75 quid for the whole unit. I'm also going up my mates to clean the egr valve to see if this makes any difference. If its fixed, will the orange engine light go out straight away or will it go eventually or have to use a fault reader?

  8. #8
    Regular Member
    Join Date
    Apr 2007
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : CDTI 150

    Trim : Design

    Engine : Z19DTH

    Year : 2005

    Default

    Should go out straight away

  9. #9
    Regular Member
    Join Date
    Aug 2010
    Location
    Blackwood
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I got new sensor, gud job I aint taken it out of sealed bag, looks like the intercooler pipe is split blowin a gale wen rev engine. I can get refund on sensor. Any idea cost of this pipe and the right name?

  10. #10
    Regular Member
    Join Date
    Aug 2010
    Location
    Blackwood
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I got new sensor, gud job I aint taken it out of sealed bag, looks like the intercooler pipe is split blowin a gale wen rev engine. I can get refund on sensor. Any idea cost of this pipe and the right name?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 18th August 2017, 06:54
  2. PLEASE HELP ERROR CODE p0100
    By signum_05 in forum Vectra C / Signum Troubleshooting
    Replies: 3
    Last Post: 20th December 2012, 20:20
  3. PLEASE HELP!! Error codes p0100 & p0105
    By signum_05 in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 1st December 2012, 13:32
  4. Flaming xp2
    By davey8oy in forum Gallery
    Replies: 53
    Last Post: 7th January 2009, 13:30

Visitors found this page by searching for:

vectra fault p0100

vectra p0100-21

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •