User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Spanner light :(

  1. #1
    Regular Member
    Join Date
    Feb 2011
    Location
    South Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Question Spanner light :(

    Ok, after searching and googling and turning the engine off and on a tiring amount of times... Im looking for some second opinions!

    The spanner light comes on when the car revs to 3500 in 3rd or above, i can redline in first and second!? After the light comes on its in a limp mode until i turn off and on again...

    Having searched and googled ive come up with the following assumtpions of what it could be??

    Gunk?
    Boost sensor
    Crankshaft sensor
    Camshaft sensor
    Egr valve

    So confused about this as half the abbreviations used here dont exist on my old car (saxo)


    So if anyone has any suggestions i would like to hear

  2. #2
    Regular Member scotty84's Avatar
    Join Date
    Dec 2010
    Location
    Boosting in W.Mids
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Saab 9-3 Aero

    Trim : Aero

    Engine : 2.8 Turbo V6

    Year : 2006

    Mileage : 62000

    Default

    What engine is it etc? will prob help narrow it down a bit. If its 2.2 direct petrol could be fuel pump or fuel regulator problems which are common.....

  3. #3
    Regular Member
    Join Date
    Feb 2011
    Location
    South Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sorry my bad there, expected the site to put model under avatar...

    Its 1.9 cdti 120

  4. #4
    Regular Member scotty84's Avatar
    Join Date
    Dec 2010
    Location
    Boosting in W.Mids
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Saab 9-3 Aero

    Trim : Aero

    Engine : 2.8 Turbo V6

    Year : 2006

    Mileage : 62000

    Default

    Could it be that you need to clean your egr, boost control vavle etc. They get rather gunked up with soot etc. Also check your swirl plates on the manifold. Not 100% on cdti engine but im sure someone will be along to correct me lol.
    But start with the cheap diy jobs dude.

  5. #5
    Regular Member DAVIDD88's Avatar
    Join Date
    Jan 2011
    Location
    scottish region
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    dont think its egr as it should not go in to limp mode

  6. #6
    Regular Member badback's Avatar
    Join Date
    Jan 2009
    Location
    Runcorn
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Don't think the 120 has the swirl flap problems, just the 150.

  7. #7
    Regular Member
    Join Date
    Feb 2011
    Location
    South Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hmmm, if we can rule out the EGR, then when I get chance ill have to get the carb cleaner out and clean up the sensors on the inlet.. as you mentioned, nice easy DIY jobbies..

  8. #8
    Regular Member
    Join Date
    Feb 2011
    Location
    South Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cleaned EGR and spanner is still coming on at 4k ish revs...

  9. #9
    Regular Member
    Join Date
    Feb 2011
    Location
    South Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ok so i understand that there is a variable vane turbo buried in that emgine bay...

    I have been reccomended using a turbo cleaning kit made by innotec by a local mechanic? As the fault is overboosting and the product says that it can solve seized turbo vanes? Anyone had any experienxe with this?

  10. #10
    Regular Member
    Join Date
    Nov 2010
    Location
    *!dave!* - The Black Country
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Spanner light is an emmission error indicator

    I would suggest you do NOTHING until such time as correct diagnostic equipment is used to interigate the fault stored

    Do not waste your money on lotions and potions until you know why the light is on

    Any good diagnostic bod should be able to read the codes but a simple code reader is not suitable as the Vaux system is a specific system and not a generic all makes and models set of codes as per OBD etc

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Problems with Air bag light, ABS, Anti Skid & Spanner light
    By WeDesign in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 4th December 2012, 21:23
  3. Should I Have A Spanner Light aswell as an Engine Light on My Signum?
    By StreetDragster in forum Engine & Drivetrain
    Replies: 16
    Last Post: 18th August 2012, 11:57
  4. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  5. spanner light then engine management light
    By learoy69 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 12th March 2010, 20:10

Visitors found this page by searching for:

code 84 spanner and management light on and limp mode

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •