User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: CDTI 1.9 150 - Major Problems, Help!

  1. #1
    Regular Member
    Join Date
    Feb 2010
    Location
    Wolverhampton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy CDTI 1.9 150 - Major Problems, Help!

    Been having alot of trouble with what I thought starteted at the EGR, but me and me old man dug a little deeper today as theres something been there for a while needed looking at, but were unsure what they are, can you help?

    Its a rail, positioned right under where the Glow Plugs are located. The rail keeps dropping off, and it should be attached to what look like a set of valves (?). We jet-washed the block earlyer on where these are to clean all the muck out and then we discovered the engine wouldnt turn over!

    Two of the cylinders had water in them, and we presume that entered through these openings, possibly a dodgey seal or something, it would help if we knew what they were.

    After taking the injectors out, we turned it over and blew most of the water out, but before we put it all back together, we need to know what these are, their purpose and how to fix the problem of a leak, and we're not sure how that rail which i presume keeps them in place and opens/closes them at the same time, sits and is fixed. Atm there is nothing there. Its just sat on the top, and so keeps falling off...

  2. #2
    Regular Member lee1828's Avatar
    Join Date
    Jan 2010
    Location
    stockton on tees
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Its your swirl flaps bar mate, very common fault on the 150 cdti, bad design! You can try the £1 fix in the 'HOW2' or it will need a new inlet manifold, around £160 on ebay plus fitting

  3. #3
    Regular Member
    Join Date
    Jan 2011
    Location
    dunfermline
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    thats the swirl flaps mate that is the big problem you will prob need a new inlet manifold.
    this is caused by a build up of crud in the inlet caused by the egr recirculating the dirty oily exhaust gasses. it lifts the swirl flaps and causes them to dislodge at the connection you are talking about.

  4. #4
    Regular Member
    Join Date
    Feb 2010
    Location
    Wolverhampton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by lee1828 View Post
    Its your swirl flaps bar mate, very common fault on the 150 cdti, bad design! You can try the £1 fix in the 'HOW2' or it will need a new inlet manifold, around £160 on ebay plus fitting

    How SHOULD it be sat/supported/fixed?

    As it is, its just sat on the top.

    And these swirl flaps, what purpose do they serve?

  5. #5
    Full Member
    Join Date
    Dec 2010
    Location
    London
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    http://www.vectra-c.com/forum/showthread.php?t=33511

    Have a look at this

    If you cant or dont want to do this its a new manifold

  6. #6
    Regular Member
    Join Date
    Sep 2009
    Location
    scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    hey mate am having the same problem at the moment so am going down the new manifold route because if the flaps seperate then they will get induced into the engine and its new engine time

  7. #7
    Regular Member
    Join Date
    Feb 2010
    Location
    preston
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    i've run withouth the swirl bar for 18 months. runs ok but loosing a bit of boost i'm sure

    try using a socket and extension bar to move swirls 1 2 + 4 ( 3 is moved by actuator). this will tell you if valves are seized.

    the £1 fix is really a temp fix.

    you need a new manifold, as do i, but in the medium term, you can run without it.

    just make sure your egr is nice and tidy.

  8. #8
    Regular Member
    Join Date
    Feb 2010
    Location
    Wolverhampton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    New manifold... is the design improved or is it the same?

    It's stuck in limp mode now. Wont go above 3k Revs and struggles to hit 40. This was after trying the £1 fix. Gonna revert when I get chance and take the linkage off all together.

    Deffinatly loosing boost tho, you can see oil resudue 'blowing' around the swirls when the engine is running.

    F*cking thing

  9. #9
    Regular Member
    Join Date
    Jan 2011
    Location
    Bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default no fix

    Got the same problems with my vectra. Just got it towed into a vx dealer tonight, will post when its fixed. If we all complain to vx as this seems to b a common fault maybe we might get some compo, thoughts please gentlemen.

  10. #10
    Regular Member
    Join Date
    Feb 2010
    Location
    Wolverhampton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by apache653 View Post
    Got the same problems with my vectra. Just got it towed into a vx dealer tonight, will post when its fixed. If we all complain to vx as this seems to b a common fault maybe we might get some compo, thoughts please gentlemen.

    Compo with Vx? Probably got more chance of plaiting ****.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.2dti major idle problems
    By dieseld4 in forum Troubleshooting
    Replies: 6
    Last Post: 4th March 2011, 14:35
  2. 2.0T Major Problems!
    By cold-chilli in forum Engine & Drivetrain
    Replies: 10
    Last Post: 24th March 2010, 17:45
  3. Windscreen - MAJOR problems
    By RobW in forum Bodywork & Interior
    Replies: 15
    Last Post: 12th November 2009, 01:13
  4. No power after major problems
    By adam3682 in forum Troubleshooting
    Replies: 14
    Last Post: 4th August 2009, 15:16
  5. a few weeks on from no power after major problems
    By adam3682 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 23rd July 2009, 08:36

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •