User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: Climate Control Blower Problem

  1. #1
    Regular Member 24vElite's Avatar
    Join Date
    Jun 2005
    Location
    Rustington, West Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Climate Control Blower Problem

    Help - 54 plate Signum Elite (pre-facelift) with climate control. On way home last night blower suddenly started blowing at full level. No response from the central fan speed control dial or either temperature control dials. Pressing the max defrost button increases fan speed slightly and pressing auto reduces it again slightly.
    Blower remains blowing even with ignition off and key removed. Only way to switch off is to pull the 30A air con fuse from the passenger dash. Other fuses relating to interior fan have no effect.
    I know there is a resistor ptoblem with non climate control cars but is there a similar problem with ECC cars?
    Any help gratefully received.
    Last edited by 24vElite; 11th February 2011 at 15:56. Reason: typo

  2. #2
    New Member
    Join Date
    Feb 2013
    Location
    Peterborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Design

    Trim : Half Leather

    Engine : 1.9CDTI

    Year : 2005

    Default

    Hi, Did you find out what caused this as I have the same problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Climate control problem help!
    By CallumHill in forum Troubleshooting
    Replies: 2
    Last Post: 18th December 2012, 23:20
  2. Climate control problem
    By CallumHill in forum Troubleshooting
    Replies: 1
    Last Post: 11th December 2012, 23:58
  3. Heater Blower not working on Climate Control Model
    By wifesgotasignum in forum Troubleshooting
    Replies: 6
    Last Post: 14th June 2012, 09:54
  4. Is blower motor resistor pack same on climate control models?
    By Partyvan in forum Electrical & ICE (including SatNav)
    Replies: 11
    Last Post: 26th April 2011, 13:39
  5. Another climate control problem
    By 24vElite in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 8th May 2008, 21:08

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •