User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: ambient air temp sensor fault

  1. #1
    Regular Member monty2000's Avatar
    Join Date
    Sep 2009
    Location
    swansea
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Pre Face, Colour Coded, CR Tech Box, Pipercross Panel filte, Blanked EGR :-)

    Trim : Club

    Engine : 1.9cdti 16v

    Year : 2005

    Default ambient air temp sensor fault

    for the last six months ive been havig probs with my engine management light coming on intermitently. (car with spanner through it). on ignition. (dissapears on start up).
    My mate has reset it 3 times for me now. My temp reads fine at all times. ive read up the ambient air temp sensor is the outside temp reader which is displayed on the dash. why would this throw an engine management issue??
    ive had a look but cant find anything on this issue.
    is it w???orth changing it or maybed giving the electrical connectors a good clean.

  2. #2
    Regular Member gtr1000's Avatar
    Join Date
    Dec 2007
    Location
    Carmarthen
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Sri

    Engine : 140 Ecoflex S/S

    Year : 2013

    Default

    I'd say that the fault you're getting is the ambient air temp being measured by the MAF sensor, ie. the air temp being drawn into the engine, not the sensor that measures the air temp that's displayed on the dash as the "outside air temp".

    Cleaning the MAF sensor might get rid of the problem.

    Went through exactly what you've described and replaced two "good" air temp sensors, the ones in the bottom grille beneath the bumper. I then twigged it was the MAF sensor, cleaned it and all was good for 12 months. Spanner light came back, so cleaned it again.

    Have you noticed a drop in mpg?

  3. #3
    Regular Member monty2000's Avatar
    Join Date
    Sep 2009
    Location
    swansea
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Pre Face, Colour Coded, CR Tech Box, Pipercross Panel filte, Blanked EGR :-)

    Trim : Club

    Engine : 1.9cdti 16v

    Year : 2005

    Default

    Quote Originally Posted by gtr1000 View Post
    I'd say that the fault you're getting is the ambient air temp being measured by the MAF sensor, ie. the air temp being drawn into the engine, not the sensor that measures the air temp that's displayed on the dash as the "outside air temp".

    Cleaning the MAF sensor might get rid of the problem.

    Went through exactly what you've described and replaced two "good" air temp sensors, the ones in the bottom grille beneath the bumper. I then twigged it was the MAF sensor, cleaned it and all was good for 12 months. Spanner light came back, so cleaned it again.

    Have you noticed a drop in mpg?
    i dont really know mate. as i dont have onboard computer (mpg calculator thingy). since ive had it i have really thought its been pretty crap on juice.good if drivig very slow. but on average no better than my 1.8 16v ecotec petrol astra. always put it down to the turbo. could u provide any links on the cleaning process please?
    Last edited by monty2000; 7th February 2011 at 22:37.

  4. #4
    Regular Member monty2000's Avatar
    Join Date
    Sep 2009
    Location
    swansea
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Pre Face, Colour Coded, CR Tech Box, Pipercross Panel filte, Blanked EGR :-)

    Trim : Club

    Engine : 1.9cdti 16v

    Year : 2005

    Default

    can anyone provide a link to a maf sensor cleaning how 2 please?. cant find one

  5. #5
    Regular Member gtr1000's Avatar
    Join Date
    Dec 2007
    Location
    Carmarthen
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Sri

    Engine : 140 Ecoflex S/S

    Year : 2013

    Default

    Quote Originally Posted by monty2000 View Post
    can anyone provide a link to a maf sensor cleaning how 2 please?. cant find one
    No How 2's IIRC but these finds might help http://www.vectra-c.com/forum/search...archid=5963550

  6. #6
    Regular Member delboy2028's Avatar
    Join Date
    Jan 2010
    Location
    grimsby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall

    Trim : 150

    Engine : 1.9 cdti

    Year : 54

    Default

    i have this problem p0070 Ambient Air Temperature Sensor but my maf sensor is brand new yet my car is dropping revs

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. strange ambient air temp
    By taxidriver50005 in forum Engine & Drivetrain
    Replies: 9
    Last Post: 15th April 2012, 14:35
  2. Temp sensor
    By dezzyb66 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 21st November 2011, 21:23
  3. Temp sensor
    By Guss in forum Engine & Drivetrain
    Replies: 0
    Last Post: 6th September 2011, 08:34
  4. Temp Sensor
    By JSYSH466Y in forum Styling
    Replies: 10
    Last Post: 20th February 2009, 00:41
  5. Temp Sensor
    By ghostrider in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 7th May 2006, 22:45

Visitors found this page by searching for:

zafira ambient temp sensor

faulty ambient air temperature sensor

ambient air temperature sensor

vectra c does outside air temperature sensor affect engine

ambient air temperature sensor vectra c

vectra c ambient air temperature sensor

vauxhall frontera ambient sensor

vauxhall zafira ambient air temperature sensor

vectra c inside temperature

vectra c ambient temperature sensor

vauxhall zafira air temperature sensor fault

vauxhall zafira ambient air temperature reading -40

vectra ambient air temperature sensor malfunction

ambient air temperature sensor issues vauxhall vectra 2004

zc vectra outside temperature doesnt work

where is the ambient air temperature sensor located on a vectra c

vectra c Ambient Air Temperature Sensor Circuit

vectra c air temp sensor

vauxhall zafira ambient air temp giving incorrect reading

vauxhall zafira 1.9cdti temperature sensor fault

2008 1.9 vectra ambient air temperature sensor

y20dth ambient air sensor location

p0070 vectra c

zafira cdti faulty outside air temperature

where is temperature sensor zafira b 1.9 dti

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •