User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: 2006 Vectra In Limp Mode

  1. #1
    New Member
    Join Date
    Feb 2011
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2006 Vectra In Limp Mode

    Hi,

    Yesterday my Vectra 1.8 Petrol 2006 went into Limp mode which made the car very unresponsive when accelerating though does not cut out and can run the car at low speeds.

    The emission light on dashboard came on at the same time.

    I have had a independent mechanic run a diag and he in confident it is the
    ignition coil pack.

    Does that sound like the symtoms for a faulty Coil?

    Thanks

  2. #2
    New Member
    Join Date
    Feb 2011
    Location
    liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by PAULJG View Post
    Hi,

    Yesterday my Vectra 1.8 Petrol 2006 went into Limp mode which made the car very unresponsive when accelerating though does not cut out and can run the car at low speeds.

    The emission light on dashboard came on at the same time.

    I have had a independent mechanic run a diag and he in confident it is the
    ignition coil pack.

    Does that sound like the symtoms for a faulty Coil?

    Thanks
    That happened to me and it was o2 sensor

  3. #3
    New Member
    Join Date
    Feb 2011
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    whats the o2 sensor..Thanks

  4. #4
    New Member
    Join Date
    Feb 2011
    Location
    liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by PAULJG View Post
    whats the o2 sensor..Thanks
    oxygen sensor

  5. #5
    New Member
    Join Date
    Feb 2011
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    How much did it cost you to get fixed?? Thanks

  6. #6
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    a coil pack can cause a misfire which would cause the engine to run poorly - to prevent significant and furhter damage the car COULD go into limp home mode..... did the garage give you a fault code ?? or just told you it was coil related ?

    0-Large smile ......every time it's driven

  7. #7
    New Member
    Join Date
    Feb 2011
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It was a mobile Mechanic who spent 10mins with the car. I didn't get the fault codes

  8. #8
    New Member
    Join Date
    Feb 2011
    Location
    liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by PAULJG View Post
    How much did it cost you to get fixed?? Thanks
    cost me £400ish fitted but there are 2-3 reasons it would go into limp mode

  9. #9
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by fluffy25 View Post
    cost me £400ish fitted but there are 2-3 reasons it would go into limp mode
    there are more than 2-3 reasons why it would go into limp home mode

    air leaks, plugs, coil packs, fuel issues, 02 sensors etc

    if the mobile mechanic HAS read and diagnosed a coil pack issue and you paid for that diagnosis if he was wrong then i would be asking for a refund

    but as you initially asked - yes the fault could be caused by a coil pack

    0-Large smile ......every time it's driven

  10. #10
    New Member
    Join Date
    Feb 2011
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by deztroyer View Post
    there are more than 2-3 reasons why it would go into limp home mode

    air leaks, plugs, coil packs, fuel issues, 02 sensors etc

    if the mobile mechanic HAS read and diagnosed a coil pack issue and you paid for that diagnosis if he was wrong then i would be asking for a refund

    but as you initially asked - yes the fault could be caused by a coil pack
    Thanks. What quick responses. Great Forum. A least i know now that the coil could be possible causing the Limp mode issues. Thanks All. We update and tell you the outcome.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra 2.2 SRi (22se) EML on limp home mode
    By james chambers in forum Engine & Drivetrain
    Replies: 2
    Last Post: 4th November 2012, 20:52
  2. limp mode above 2500rpm Vectra 2006 120bhp 1.9cdti
    By mani911gt3 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 3rd September 2011, 20:07
  3. Help Needed - 1.8 Vectra in Limp Mode
    By Kyser143 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 2nd October 2010, 21:33
  4. 2.0 DTi 03 Vectra - Limp Mode - Help!!
    By scrumpycider in forum Engine & Drivetrain
    Replies: 8
    Last Post: 26th August 2009, 21:57
  5. help limp mode on vectra 1.9cdti
    By signum junkie in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 27th April 2008, 22:38

Visitors found this page by searching for:

what causes limp mode vectra

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •