User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: (2.2DTI SRI)‘LIMP HOME MODE’ icon. Turbo stops working!

  1. #1
    Regular Member lostdog's Avatar
    Join Date
    Oct 2010
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Angry (2.2DTI SRI)‘LIMP HOME MODE’ icon. Turbo stops working!

    Hello,

    I am very confused......My car (2.2DTI SRI) keeps showing the ‘LIMP HOME MODE’ icon. The Turbo stops working!


    I have changed all vacuum pipes and cleaned the ‘boost sensor’!

    It seemed to happen this morning just as I came to stop at the lights. Engine still cold drove for about half a mile.

    I turned the engine off and the next set of lights and waited for about 2 mins. Then restarted and the light did not come back on!

    What would cause that?

    Thank you

  2. #2
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats






  3. #3
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    53 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    Failing that read fault codes

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  4. #4
    Regular Member lostdog's Avatar
    Join Date
    Oct 2010
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If it needs a clean, why would it start working ok, after I restarted the car?

  5. #5
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have a look round the vac system... it could be just an air leak or an intermittent sticking of the valve.

    hth

  6. #6
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I really think you need to get the codes read now. Dont go to Vauxhall as they will charge about £75. Most back street garages will have code readers or you could buy one online for about £20-30.

    If you are ever down in Plymouth I'd do it for you!

  7. #7
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    You did say in earlier posts that you had a split in the intercooler hose. Have you patched that up yet r got new hose?

  8. #8
    Full Member spennny's Avatar
    Join Date
    Jun 2008
    Location
    Blantyre
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Try reading the codes using the pedals , it may work ?

  9. #9
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Vac pipes? Do you mean turbo hoses?
    Now I need a turbo to keep up!

  10. #10
    Regular Member lostdog's Avatar
    Join Date
    Oct 2010
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have replaced all my vacuum hoses with nice blue ones! I thought that would be the end of all this stuff..............

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Limp Home Mode
    By spennny in forum Engine & Drivetrain
    Replies: 6
    Last Post: 21st October 2012, 20:28
  2. Can limp home mode correct itsself? 3.0 turbo diesel
    By malk in forum Troubleshooting
    Replies: 7
    Last Post: 15th August 2012, 06:52
  3. Turbo stops working, when ever it likes...? HELP
    By lostdog in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 30th March 2011, 10:55
  4. limp home mode
    By trickster75 in forum Diesel Engine related
    Replies: 6
    Last Post: 18th July 2010, 16:58
  5. 2.2 DTi SRi - TURBO STOPS WORKING WHILE DRIVING
    By irmscher-brett in forum Engine & Drivetrain
    Replies: 6
    Last Post: 16th February 2010, 20:29

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •