User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: cdti 150..very smokey,lagy...help please!

  1. #1
    Regular Member sr150i's Avatar
    Join Date
    Oct 2010
    Location
    belfast
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy cdti 150..very smokey,lagy...help please!

    ok here it goes...

    i have a 2005 sri 150 i bought about 5 months ago..
    always thought they were a lively enuf thing..

    but ever since having it its giveing out loads of smoke on boost?it fils the road with suit and i can notice this more when dark and i look in my rear view with other cars headlights!..
    and sometime when i boost it on it cuts out at the spanner comes on the dash?and the EML some times aswel
    the car is very lagy it takes for ever to come on boost..

    some people are saying manifold swirl valves?
    egr valve?-why would it have lots of lag?
    boost sensor?-but why would it be smoney?
    any one else had simalor problems?

    thanks

  2. #2
    Full Member GazVXLINE170's Avatar
    Join Date
    Jun 2007
    Location
    Scotland
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default

    Ok at the moment I suspect either:

    - Check Swirl bar rod/Swirls move when engine is revved above 2,500rpm.
    - EGR valve
    - Split hose
    - Boost sensor is dirty


    Check swirl bar - is it off? Remove engine vanity cover and look down behind the fuel rail (large silver tube onto of the engine). You will see a metal linkage if this is off it could be source of your troubles. If is working is there any oil sweat? If so swirl flaps are on the road out or have failed. If the rod is still connected check it moves by getting someone to rev it past 2,500rpm while you watch. If it doesn't move the drive module is knackered. However this usually puts on the EM light.

    Have look, purchase EGR gaskets from the Dealer and clean the EGR valve and replace.

    Check all hoses for splits - particularly the one heading to the manifold (large rubber hose wnich sits between the engine and battery compartment - it heads into the engine).

    Give boost sensor a clean as per How2.

    If it's not any of the above then I would say the intercooler has split - quite common.

    Gazza4
    Insignia VX-Line Nav CDTI 170.

  3. #3
    Regular Member sr150i's Avatar
    Join Date
    Oct 2010
    Location
    belfast
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    thanks alot mate..it check these things in the morning and let u know how i get on thanks again!

  4. #4
    Regular Member sr150i's Avatar
    Join Date
    Oct 2010
    Location
    belfast
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    also wats DPF blockage?

  5. #5
    Full Member GazVXLINE170's Avatar
    Join Date
    Jun 2007
    Location
    Scotland
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by sr150i View Post
    also wats DPF blockage?
    Unless yours is auto it won't affect you m8.

    Gazza4
    Insignia VX-Line Nav CDTI 170.

  6. #6
    Regular Member peadar's Avatar
    Join Date
    Aug 2007
    Location
    in the glens of Antrim N Ireland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    also check the small vacum hose at the front cross member

  7. #7
    Regular Member sr150i's Avatar
    Join Date
    Oct 2010
    Location
    belfast
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    ok went out in the vectra tonite and it wont go over 3000 rpm! i swear i would have set it on fire the mood it has put me in..i kept having to turn the engine off and restart it so it would boost for the cuple of seconds then cut out again!!!..

  8. #8
    Full Member GazVXLINE170's Avatar
    Join Date
    Jun 2007
    Location
    Scotland
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sounds like a loss of boost any way. More likely the intercooler tbh as it has the same symptoms mine did, but check the boost hose and hose coming out of the MAF first.

    Gazza4
    Insignia VX-Line Nav CDTI 170.

  9. #9
    Regular Member sr150i's Avatar
    Join Date
    Oct 2010
    Location
    belfast
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    all my we boost hoeses under the engine cover need replaceing but would this be the prob?the car was driving 120% until the last cuple of days..and i bet intercoolers afrent cheap!

  10. #10
    Full Member GazVXLINE170's Avatar
    Join Date
    Jun 2007
    Location
    Scotland
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by sr150i View Post
    all my we boost hoeses under the engine cover need replaceing but would this be the prob?the car was driving 120% until the last cuple of days..and i bet intercoolers afrent cheap!

    Intercooler - £500ish.

    How do you know they need replacing? Are they split?

    Gazza4
    Insignia VX-Line Nav CDTI 170.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Smokey Vec
    By SteveH in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 12th October 2010, 15:57
  2. Smokey V6 CDTI after idling...
    By myveccy in forum Engine & Drivetrain
    Replies: 1
    Last Post: 17th May 2010, 15:41
  3. Smokey Sri
    By MarkEllo220864 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 27th March 2009, 11:56
  4. Smokey CDTI
    By MattW in forum Diesel Engine related
    Replies: 4
    Last Post: 21st September 2008, 00:32
  5. Smokey V6 CDTI SRI
    By woodster in forum Engine & Drivetrain
    Replies: 2
    Last Post: 23rd August 2005, 09:21

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •