User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Advice needed please :)

  1. #1
    Regular Member edwardabud86's Avatar
    Join Date
    Aug 2009
    Location
    luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Angry Advice needed please :)

    I have a wee problem with my vectra. Kinda hard to explain, but basically, when i go over a bump, drain, pot hole etc on the driver side the the car feels ok, but when i go over them on the left side the back end always kicks out. Feels like the car snakes and its quite dramatic.
    Any clues as to what it may be?? Its more noticable at higher speeds so B roads at 60mph can be a bit hairy at times!
    Kind of feels like the back ends doing something completely different to the front!

  2. #2
    Regular Member Daywalker's Avatar
    Join Date
    Aug 2007
    Location
    Kaunas raj
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Qashqai

    Trim : Visia

    Engine : 1.5dci

    Year : 2010

    Default

    Could be the upper arms are worn and need changing

  3. #3
    Regular Member paul_sri150's Avatar
    Join Date
    Apr 2010
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by edwardabud86 View Post
    I have a wee problem with my vectra. Kinda hard to explain, but basically, when i go over a bump, drain, pot hole etc on the driver side the the car feels ok, but when i go over them on the left side the back end always kicks out. Feels like the car snakes and its quite dramatic.
    Any clues as to what it may be?? Its more noticable at higher speeds so B roads at 60mph can be a bit hairy at times!
    Kind of feels like the back ends doing something completely different to the front!
    what wheels have you got on? it could be 'traming'

    I get it all the time with having 235's on

  4. #4
    Regular Member
    Join Date
    Sep 2009
    Location
    Audley STAFFS
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by paul_sri150 View Post
    what wheels have you got on? it could be 'traming'

    I get it all the time with having 235's on
    so do I and I only have 215s on, have found keeping the pressure up a bit makes a big difference,, also dont think its you upper control arms, made no difference to mine.

  5. #5
    Regular Member Tam80's Avatar
    Join Date
    Aug 2010
    Location
    Dundee-Motherwell
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Check All Bushes/Etc..Replace AnyThing That`s F*****

    Then Get 4 Wheel Alignment Done

  6. #6
    Regular Member Graham's Avatar
    Join Date
    Sep 2005
    Location
    Macclesfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Focus

    Trim : Titanium

    Engine : 1.6 TDCI

    Year : 62

    Mileage : 9K

    Default

    100 % your rear shocks mate. Commom problem when they are seized. Makes the back end skip out and can be dangerous.

    Had the same problem about 3 years ago.

    Only 2 bolts hold the rear shocks on. Could take 1 off them of. Try to compress it and that will prove its seized.

    Then change them to Blisten B4. Take a look at the thread below.

    http://www.vectra-c.com/forum/showthread.php?t=10778
    Last edited by Graham; 30th January 2011 at 10:17.

  7. #7
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    70 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    Moved

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  8. #8
    Regular Member edwardabud86's Avatar
    Join Date
    Aug 2009
    Location
    luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Graham View Post
    100 % your rear shocks mate. Commom problem when they are seized. Makes the back end skip out and can be dangerous.

    Had the same problem about 3 years ago.

    Only 2 bolts hold the rear shocks on. Could take 1 off them of. Try to compress it and that will prove its seized.

    Then change them to Blisten B4. Take a look at the thread below.

    http://www.vectra-c.com/forum/showthread.php?t=10778
    I thought it may be this! Ive just put b4's on the front so will order some for the back! only £38 each. im gone being getting the car track and balanced soon to as its a bit off. Cheers for the advice guys!

  9. #9
    Regular Member YT07's Avatar
    Join Date
    Jan 2011
    Location
    south cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yes deffo the shocks mate,i had this on the wifes fiesta where the back end skipped out bad and it turned out one of the shocks had siezed,had both changed and it`s like new again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Advice Needed
    By Doddy01 in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 4th November 2010, 15:35
  2. a little advice needed please
    By mublin in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 26th August 2010, 16:11
  3. advice needed
    By iasha in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 10th July 2009, 10:42
  4. advice needed
    By taxidriver50005 in forum Bodywork & Interior
    Replies: 4
    Last Post: 1st June 2009, 15:30
  5. advice needed
    By lizard in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 12th November 2008, 19:36

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •