User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: 2.2 direct misfire/lack of power problems.

  1. #1
    Regular Member
    Join Date
    Mar 2010
    Location
    Moray
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.2 direct misfire/lack of power problems.

    Hi guys, hope someone can shed some light on this for me.
    Car has been running fine until the other day, when all of a sudden it almost died, would take any revs above 2500 and limited itself to about 20 miles an hour.
    It also threw up the car and spanner light at the same time.
    This happened while my wife was driving it home, and luckily happened in town just after she came of the main NSL road.
    I took it out for a spin and all seemed fine, till you tried to give a bit of poke, where upon it would judder about, go very slowly up the rev range and have absolutely no power at all.
    Very dangerous to drive in this condition.
    Ive changed out all the filters, oil and plugs and still runs the same.
    I cleaned out the crankcase breather hose as well, and there was a bit of gunge in there too.
    Could it be the EGR? Ive had a look through my haynes manual but still not sure exactly where it is and the best way to get it off.
    Car has one 91,000 miles so far.
    Any help or pointers would be appreciated. Thanks.

  2. #2
    Regular Member
    Join Date
    Mar 2010
    Location
    Moray
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default update

    OK, got the RAC out today to have a look. Guy hooked up his laptop and got a few codes from the car.
    He cleared them then ran the car for a while giving it some revs every now and again till spanner light came back.
    Two codes kept reappearing each time P1191 fuel rail pressure and another one which he hasnt written down. Cant remeber it either but it was something to do with port solenoid / abs traction control and that had him stumped also.
    Seems like each time you unplug the MAF on my car , it throws up the traction control light on the dash.
    Had a bit of reading around here regarding p1191, and it would appear that there was a "silent" recall on the fuel pressure regulator on the 2.2 directs.
    Ill give them a call in the morning about it.
    Anyone any other ideas?

  3. #3
    Full Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    you can check your chassis number against the recalls list on the VOSA website... i have read on here mentions of the fpr recall...

    http://www.dft.gov.uk/vosa/apps/recalls/default.asp
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  4. #4
    Regular Member hoochydady's Avatar
    Join Date
    Jan 2010
    Location
    glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi mate yip there was and still is i think a fpr recall on the 2.2 that would be my first port of call and cross your fingers it sorts it if not you could be looking at a hp fuel pump as this is also a problem area in the 2.2 and 1 last bit of advice change the oil and oil filter every 5-10 k

  5. #5
    Regular Member
    Join Date
    Mar 2010
    Location
    Moray
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the replys guys. Will let you know in the morning .

  6. #6
    Regular Member markj23's Avatar
    Join Date
    Aug 2010
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    if it throws up your asb light it will be the fuel pressure sensor there about 60 odd quid

  7. #7
    Regular Member Sean-2.2Direct's Avatar
    Join Date
    Apr 2008
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My fuel pressure sensor has gone and I have no ABS light on the dash

  8. #8
    Regular Member markj23's Avatar
    Join Date
    Aug 2010
    Location
    Luton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    when I spoke with dealer when I had problem he asked if light was on when I said yes he said that is one of the things it does so they (vaux techs) know its the sensor not the pump, weel thats what he told me

  9. #9
    Regular Member noel.nev's Avatar
    Join Date
    Feb 2008
    Location
    Pen-Y-Bryn S.Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    when my fpr went my car would not start, when it started to misfire and splutter it was the high pressure fuel pump hth

  10. #10
    Regular Member simplesi's Avatar
    Join Date
    Aug 2009
    Location
    probably off taking photos
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 1.9 cdti 150

    Trim : elite


    Year : 2006

    Default

    if its got a seimens high pressure fuel pump on it , it will probably be that, get it back to vaux and get a continental one put on my car did the same.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.2 direct misfire
    By lh_4827 in forum Engine & Drivetrain
    Replies: 52
    Last Post: 22nd November 2013, 19:55
  2. Lack of power
    By McLovinH in forum Engine & Drivetrain
    Replies: 20
    Last Post: 23rd August 2012, 22:17
  3. 2.2 Direct Misfire Problems :(
    By jonny180 in forum Engine & Drivetrain
    Replies: 31
    Last Post: 14th April 2012, 20:00
  4. 2.2 Direct 54 misfire sometimes
    By rodzynx in forum Engine & Drivetrain
    Replies: 9
    Last Post: 4th March 2012, 12:22
  5. Lack of power...
    By lightfx in forum Engine & Drivetrain
    Replies: 8
    Last Post: 20th October 2010, 14:33

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •