User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Intercooler Pipe causing spanner?

  1. #1
    Regular Member arkhan78's Avatar
    Join Date
    Nov 2007
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Intercooler Pipe causing spanner?

    Hi all

    ok had the dreaded spanner light come on a couple of times but each time it was when i was around 3000 revs. took the engine cover off this morning and had a look around the pipes ready for a egr and all the other bits to clean but noticed that my intercooler pipe was cracked and if you press it you can see through it.

    Could this be causing the spanner light to come on?

    I havent cleaned anything else yet, just tapped up the pipe and will take for a test run later?

    Also how much is a new one?

    Cheers chaps

  2. #2
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi, you havent said what engine you have but i'm guessing either the 2.0dti or 2.2dti as these tend to be the engines that split theirt hoses. Vauxhall were a bit tight with the quality of materials when they put these hoses on. Yes that split would be causing the Limp Home Mode and you probably noticed some hissong too?

    You have 3 options:

    1. Buy from Vauxhall but they dont sell indivdual hoses just the whole lot which is £££
    2. Replace the hose that has failed with a moulded silicone one from ebay for about £63 each. Here are the links depending on which one it is:

    http://cgi.ebay.co.uk/Vectra-C-Turbo...item3a61fab712

    http://cgi.ebay.co.uk/Vectra-C-turbo...item3a620d4187

    3. Make your own like I did for about £20-£30:
    http://www.vectra-c.com/forum/showthread.php?t=116528

  3. #3
    Regular Member arkhan78's Avatar
    Join Date
    Nov 2007
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers Innes, your home made version looks good might have to consider it if i cant get a cheap enough pipe.

    Would it not be advisable to use a used one? from a scarp yard?

    Anyway the temporary tape didn't work as it spannered again at around 3k revs this morning.

  4. #4
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    You need half a roll of reinforced Duck tape like in my photo for it not to split. Even then my tape lasted about a week before it started falling apart.

    You can buy a 2nd hand pipe but it may last you years or months. Its difficult to tell what condition these pipes are in as they tend to go from the inside out. So it may look good from the outside but could be screwed on the inside. Ok for a temporary measure.

    If you want piece of mind I'd get the moulded silicone hose of ebay especially if its the hose on the left of the engine bay (as you look at it from the front). If its the right inter cooler hose then again get the moulded one or have a go at making one like mine. Note the end of my thread. I changed the Jubilee clip to a T-Bolt Clamp as its better suited to grip silicone hoses to metal pipes..

  5. #5
    Regular Member arkhan78's Avatar
    Join Date
    Nov 2007
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ok ordered a silicon moulded one off ebay now mate, cheers.

    Another issue, i have taped up the pipe as best i can for the time being but noticed the turbo doesnt really kick in much and its driving like a normal diesel transit van now!

    When the spanner light does come on at 70 it does cut off the turbo and to re-engage it i have to switch off and restart. Going from 1 up to 3 seems like a massive task for the car. No excessive smoke so do you think there is another hose issue?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. dti intercooler pipe
    By b21playa in forum Engine & Drivetrain
    Replies: 47
    Last Post: 9th February 2011, 21:40
  2. Cold weather causing spanner warning light to come on???
    By supersione in forum Vectra C / Signum Troubleshooting
    Replies: 7
    Last Post: 18th December 2010, 15:58
  3. intercooler pipe
    By tigertye in forum Engine & Drivetrain
    Replies: 2
    Last Post: 3rd October 2010, 12:29

Visitors found this page by searching for:

vectra c 2.2 dti intercooler

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •