User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: is this correct

  1. #1
    Regular Member andy76's Avatar
    Join Date
    Dec 2008
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : cdti 150

    Trim : sri

    Engine : z19dth

    Year : 2005

    Default is this correct

    for my z20net
    http://cgi.ebay.co.uk/FORGE-VECTRA-T...item4cf3b9252d

    this says it's Atmospheric, i thought the 2.0T's needed to be recirclating dv

    heeeeelp im about to order

  2. #2
    Regular Member andy76's Avatar
    Join Date
    Dec 2008
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : cdti 150

    Trim : sri

    Engine : z19dth

    Year : 2005

    Default

    anyone, i know there not everyones cuppa but dont want to order to find it's wrong

  3. #3
    Full Member ROCKATANSKY's Avatar
    Join Date
    Apr 2008
    Location
    suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    There are a couple that have fitted these, but personally not sure. However it's a Forge item and they know what they're doing so if they so say then so it is. You could always phone them to double check

  4. #4
    Regular Member andy76's Avatar
    Join Date
    Dec 2008
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : cdti 150

    Trim : sri

    Engine : z19dth

    Year : 2005

    Default

    just been on forge website but it aint showing anything for a vectra.
    might just try it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is this the correct Kit?
    By Vectra Dan SRi in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 2nd January 2013, 00:07
  2. These the correct ones?
    By golfpro in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 28th December 2012, 03:06
  3. correct oil
    By Dougb in forum Engine & Drivetrain
    Replies: 5
    Last Post: 27th April 2010, 14:27
  4. have VX used correct oil?
    By wardy in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 30th April 2007, 20:58

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •