User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: whining egr valve

  1. #1
    Regular Member
    Join Date
    May 2010
    Location
    belfast
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default whining egr valve

    hi everyone, as the title says, my egr valve whines??? the car will drive all day everyday with the egr valve disconnected, but obviously will be in limp mode. i have cleaned the throttle body and egr and when it is reconnected the car will go into limp mode and stop. i have now noticed that the egr valve is whining. as soon as it is disconnected the whining stops. if i reconnect and the whining has stopped the car will start, and so on......whining starts car stops, whining stops, car starts..???? is there anything can be done to rectify this or is a new one on the cards???
    MY CAR IS A 04 2.2DTI ESTATE.

  2. #2
    Full Member paul_sri150's Avatar
    Join Date
    Apr 2010
    Location
    Liverpool
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    do you get EML?
    Engine-DTUK eco3,K&N panel filter/airbox mod1&2,samco vac hoses,covers detailedExt-XP spliter,sig fogs,eyebrows,tinted side repeaters&rear lights,debadged,CC'd vxr valance/boot strip/calipers,heated jets,flatblade wipers,reverse cam,mtec bulbs,twin exhaust,8k HIDs,snowflakes,opel grill/insig griffinInt-TV/NAV/DVD,led&white GID conversion,footwell lighting,cooled g'box,custom headrests,blinds,JBL sub/amp

  3. #3
    Regular Member
    Join Date
    May 2010
    Location
    belfast
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    spanner light comes on.

  4. #4
    Full Member paul_sri150's Avatar
    Join Date
    Apr 2010
    Location
    Liverpool
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    get a code reader and find fault code, it could be something else causing it, if not it might be a new EGR :S
    Engine-DTUK eco3,K&N panel filter/airbox mod1&2,samco vac hoses,covers detailedExt-XP spliter,sig fogs,eyebrows,tinted side repeaters&rear lights,debadged,CC'd vxr valance/boot strip/calipers,heated jets,flatblade wipers,reverse cam,mtec bulbs,twin exhaust,8k HIDs,snowflakes,opel grill/insig griffinInt-TV/NAV/DVD,led&white GID conversion,footwell lighting,cooled g'box,custom headrests,blinds,JBL sub/amp

  5. #5
    Regular Member
    Join Date
    May 2010
    Location
    belfast
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    have done that already and it said throttle body sensor which has been replaced. would anything else cause the egr to go into some sort of failure and cause it to whine though?

  6. #6
    Full Member paul_sri150's Avatar
    Join Date
    Apr 2010
    Location
    Liverpool
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    if it is still throwing up the code, then it may have something to do with it still

    has the egr got full travel, all the way open/closed?
    Engine-DTUK eco3,K&N panel filter/airbox mod1&2,samco vac hoses,covers detailedExt-XP spliter,sig fogs,eyebrows,tinted side repeaters&rear lights,debadged,CC'd vxr valance/boot strip/calipers,heated jets,flatblade wipers,reverse cam,mtec bulbs,twin exhaust,8k HIDs,snowflakes,opel grill/insig griffinInt-TV/NAV/DVD,led&white GID conversion,footwell lighting,cooled g'box,custom headrests,blinds,JBL sub/amp

  7. #7
    Regular Member
    Join Date
    May 2010
    Location
    belfast
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    egr valve working great mechanically, its just been cleaned and i put a little cooper grease on the piston and it slides very very easily. i only cleaned it and the whining was almost immediate, but is intermittent

  8. #8
    Regular Member
    Join Date
    May 2010
    Location
    belfast
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    anyone else experienced this before??

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HELP! whining from the front
    By Ann in forum Suspension, Wheels & Brakes
    Replies: 7
    Last Post: 17th February 2013, 16:32
  2. whining noise
    By Swedge in forum Engine & Drivetrain
    Replies: 39
    Last Post: 21st November 2012, 23:23
  3. whining egr
    By donut in forum Troubleshooting
    Replies: 2
    Last Post: 14th January 2011, 11:56
  4. whining noise (HELP)!!!!
    By wilsons 1.8sxi in forum Engine & Drivetrain
    Replies: 4
    Last Post: 20th March 2009, 09:03
  5. Whining Brakes.
    By Russ3.2GSI in forum Engine & Drivetrain
    Replies: 0
    Last Post: 10th April 2006, 08:55

Visitors found this page by searching for:

whinnin from egr valve

Erg valve wineing noise

whine from egr valve

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •