User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Its doing my nut in (windows)

  1. #1
    Regular Member scotty84's Avatar
    Join Date
    Dec 2010
    Location
    Boosting in W.Mids
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Saab 9-3 Aero

    Trim : Aero

    Engine : 2.8 Turbo V6

    Year : 2006

    Mileage : 62000

    Default Its doing my nut in (windows)

    Hey peeps,
    Ok my windows keep steaming up, within seconds of getting in and if I go into a shop when I come out its steamed up again. I have searched threads on here and elsewhere and tried ALL the ways to solve it being:
    Wet footwells(dry), wheel well (dry), Leaks (non visable)
    Pollen filter/scuttle tray (replaced and cleaned, old filter was damp)
    Using AC (works for front windows, but steams up straight away if turned off.
    The only way is to drive around with full heat/fan settings on, rear window,AC and front windows all switched on lol. May I add I have also cleaned the windows with anti fog, rain x and auto glym glass cleaner. I have noticed my headlights and passenger fog lights also steam up lol.
    Only had the car 5 weeks but planning on getting new one just because it gets dangerous to drive with this randon steaming up.
    Cheers peeps.

    May it be worthwhile taking it to vx or a garage?

  2. #2
    Regular Member Jow20's Avatar
    Join Date
    Sep 2010
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    You must be just hot stuff!!! Lol

  3. #3
    Regular Member scotty84's Avatar
    Join Date
    Dec 2010
    Location
    Boosting in W.Mids
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Saab 9-3 Aero

    Trim : Aero

    Engine : 2.8 Turbo V6

    Year : 2006

    Mileage : 62000

    Default

    Quote Originally Posted by Jow20 View Post
    You must be just hot stuff!!! Lol
    Lol, it steams up, I steam up so I guess thats not helping haha. I never thought I could get so peed of over steam, it just does it while going down the motorway etc and I cant see anything till I turn everything on and it demists it, nearly had a prang on way home today, it was my last straw.

  4. #4
    Regular Member
    Join Date
    Sep 2009
    Location
    middlesbrough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Very strange

  5. #5
    Regular Member Jow20's Avatar
    Join Date
    Sep 2010
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My dads 08reg l200 warrior does it bad, and my missus 60 plate toyota aygo!! So i dunno what can cause it, but personally my vectra doesnt do it. Must be just individual cars??? Who knows, but roll on summer eh! Hardly any probz!! Cars seem to hate winter!

  6. #6
    Regular Member mxt's Avatar
    Join Date
    Nov 2010
    Location
    J17 M6 Sandbach, Cheshire.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I assume you are not loosing coolant? ie. a small split in heater matrix?

  7. #7
    Regular Member Grumpy1954's Avatar
    Join Date
    Mar 2010
    Location
    Newport (Shropshire)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Ford Kuga

    Trim : Titanium

    Engine : 2.0dtci

    Year : 2014

    Mileage : 1200

    Default

    How heavy and how many times did you use the AG? Took me 3 goes, laying it on quite heavy, to stop mine misting up.

  8. #8
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    and i assume that you only do short drives that are not long enough to dry out the interior = you need to have he car warm with the AC on to remove the humidity the wetter and damper the interior the longer it needs to run

    mine does the same during the week ......im only in it for a total of 10 minutes each way..... BUT on the weekenf running around for over an hour dries it out nicely ..... till the weeks routine starts again

    0-Large smile ......every time it's driven

  9. #9
    Regular Member ONEMINUTESILENCE's Avatar
    Join Date
    Jul 2010
    Location
    Skipton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Try switching the air con circulation button on & off a few times. Sometimes the small cabin inlet gets stuck. It did in my astra coupe & this solved it straight away

  10. #10
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    I had a similar problem tail end of last week.start of this week.... I put it down to the mass of damp air that gets sucked in as you open the door. I ended up sat in the carpark at work with the screen blaster on for 5 minutes on mon night before I could see enough to drive. Should get better now it's a little warmer - above +4c the aircon starts working again.
    I blame the Welsh.... we get all the wet stuff they don't want !

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Windows 7
    By steve1975l in forum General Chat
    Replies: 19
    Last Post: 17th June 2009, 16:33
  2. Windows Wipers and Windows Washers
    By kevrod79 in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 19th February 2009, 09:58
  3. Do your windows go down on their own???
    By Pepsi Max in forum Vectra C / Signum Car Chat
    Replies: 18
    Last Post: 5th February 2009, 22:27
  4. dvd,windows,help.
    By wernham in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 5th May 2008, 23:23
  5. Windows XP SP3
    By bertxuk in forum General Chat
    Replies: 9
    Last Post: 3rd February 2008, 03:36

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •