User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: HID direct and there poor service

  1. #1
    Regular Member paul wingnut's Avatar
    Join Date
    Mar 2009
    Location
    durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra sri 150


    Engine : 1900 cdti 150

    Year : 2008

    Default HID direct and there poor service

    hi, got hid's from hid direct in nov straight away problems one not working faulty ballast eventually got it changed with the cost of the postage now int one not working again spoke to them fobbed off again think theway forward is to take them off and bin them would not use these again .

  2. #2
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    they offer a 2 year warranty - if there not fit for purpose - send them back for a full refund - you might not get the postage back - but its got to be better than nothing back ??

    0-Large smile ......every time it's driven

  3. #3
    Regular Member
    Join Date
    May 2009
    Location
    Norwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats


    Trim : SXi

    Engine : 2.2


    Default

    I had probs with the bulbs blowing and they were useless, would not refund anything despite endless e-mails. I was really disapointed with their service. I bought some more bulbs off another HID supplier and they have worked ever since without any faults, yet HID direct kept blowing within 2/3 days of using them.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. VWP..... Poor service
    By krazylegz in forum The 'Off Topic' room
    Replies: 7
    Last Post: 19th March 2012, 10:53
  2. Poor Service - Lookers Warrington
    By Desmondo in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 4th August 2011, 15:48
  3. Signum 2.2 Direct - misfire?/vibration/poor acceleration
    By Fenris in forum Engine & Drivetrain
    Replies: 15
    Last Post: 31st July 2011, 23:32
  4. 2.2 direct serious judder/poor running!help!
    By leem82 in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 9th October 2010, 10:59
  5. SIO Communications - Poor Service?
    By andythilo in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 25th November 2006, 08:36

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •