User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Poorly 1.9 CDTi

  1. #1
    New Member
    Join Date
    Dec 2010
    Location
    Berkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Poorly 1.9 CDTi

    Guys,

    I'm having a problem with my 2006 1.9 CDTi 150.

    Just before Christmas my alternator failed and since getting it back on the road I've had major performance issues, I'm not sure if the alternator is related at all but I'm mentioning it!

    Symptoms are, spanner light is on, car has absolutely no power whatsoever.
    0-60 would be measured in minutes rather than seconds!
    Engine will rev to just over 3000 RPM but takes a while to get there.

    So far I've blanked off the EGR valve with 2mm steel plate at both the square and oval outlets, this seemed to fix the problem initialy, however the next day the car felt like it had been dropped into treacle. I've now cleaned the boost solenoid and replaced the small 4mm vacuum pipes.

    On first start up the car feels really responsive until I change gear, at that point it's flat again, it's as if the car is dropping into limp home. EML is on but I don't have a fault code reader yet (OP Com ordered) I don't want to assume that the EML is the EGR valve reporting being blocked, I'm hoping my neighbour is going to remember to bring his fault code reader home this evening to see what is logged to help narrow things down.

    Any suggestions as to where to look next?

  2. #2
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    The egr's are temperamental!, so cleaning it thoroughly as in the 'how 2' section is essential, the solenoid half needs doing, also making sure the hole in the head where the egr bolts onto is cleaned out, remove/clean/check the injector connectors, checking/cleaning the throttle body is also a good idea, that's also in the how 2 section.

  3. #3
    New Member
    Join Date
    Dec 2010
    Location
    Berkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'll have a look at the Throttle body this weekend.
    The EGR valve is completely blanked in a vain attempt to remove it from the equation altogether.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Poorly Cdti V6
    By Mick B in forum Engine & Drivetrain
    Replies: 12
    Last Post: 9th August 2012, 20:43
  2. 1.9 16v cdti sometimes starts very poorly when warm help plz?
    By rozzer2006 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 8th July 2012, 13:55
  3. Car is poorly :(
    By sjk in forum Vectra C / Signum Troubleshooting
    Replies: 10
    Last Post: 16th December 2010, 13:58
  4. Is it poorly?....
    By bobby-tupper in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 15th December 2008, 14:22
  5. car is poorly
    By andy.l in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 18th June 2008, 09:24

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •