User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Fault codes..One I was expecting

  1. #1
    Regular Member
    Join Date
    Aug 2009
    Location
    herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Fault codes..One I was expecting

    Been having the spanner light appear during driving the first few mins on these cold mornings, and assumed it would be the glow plugs faulty as after a few mins driving the spanner light would go out - no driving related issues at all.

    Fault codes

    P0380-08 Glow device General Error - glow plugs need replacing then? Can someone confirm that is all this fault is? On a diagnostic check on output tests - glow time relay test it says glow time relay inactive 12v, this i assume is because the car was already warm?

    Also didnt expect;

    U2139-00 Canbus no communication with CIM (steering control module) - eh? anyone please?

    and

    B3794-08 Switch cruise control circuit malfunction. This will be accepted as my cruise control has suddenly switched off on occasions when driving on motorway in one gear, set speed. Easy fix?

    Many thanks in advance for your help.

    Colin.
    Last edited by bigmac; 30th December 2010 at 21:05. Reason: wording better

  2. #2
    Regular Member
    Join Date
    Jun 2010
    Location
    Huddersfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ignore the middle one I got that and several similar on mine. VX advise to disregard unless you do gave problems.

  3. #3
    Regular Member
    Join Date
    Aug 2009
    Location
    herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sorry about op com comments, wish to retract if could.

  4. #4
    Admin & Membership Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    77 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    Quote Originally Posted by hertscol View Post
    sorry about op com comments, wish to retract if could.
    Done

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  5. #5
    Regular Member Innes's Avatar
    Join Date
    Mar 2010
    Location
    Plymouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah dont worry about the Canbus error reading. It just means it failed reading that certain part of the scan. It doesnt indicate a problem.


    Remeber PRESENT - means the fault is currently there at the time of scan.
    NOT PRESENT - Means its an old stored code and at the time of the scan it wasnt present (although it may still be an intermitant problem).

  6. #6
    Regular Member
    Join Date
    Apr 2007
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : CDTI 150

    Trim : Design

    Engine : Z19DTH

    Year : 2005

    Default

    B3794-08 Switch cruise control circuit malfunction. This will be accepted as my cruise control has suddenly switched off on occasions when driving on motorway in one gear, set speed. Easy fix?

    Probably the clutch pedal spring. Spring gets weak and does not support the weight of the pedal this activates the clutch pedal switch so the ECU thinks the clutch is depressed and therefore will not allow cruise control selection.
    With a 'suitable diagnostic program', scan the ECU, select measuring blocks, then run down the drop down menus til you find the clutch and brake pedal switches (2 brake ccts to check). With ign on should all read inactive, when depressed should change to active.
    If the switches change between active/inactive with very very light (feather like) pressure then spring is u/s.
    If either switch reads active when not pressed put your foot under the pedal and lift the pedal, if switch then goes inactive probably spring if remains active probably the switch.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. fault codes
    By GSi-Col in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 10th March 2012, 00:00
  2. fault codes
    By bigcarp1953 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 13th December 2010, 15:04
  3. Fault Codes?
    By countduckula55 in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 3rd October 2010, 21:29
  4. 2 fault codes
    By bigmac in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 1st April 2009, 12:49
  5. Fault Codes
    By cosmic in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 29th March 2009, 08:19

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •