User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Windscreen Washers

  1. #1
    Regular Member RobW's Avatar
    Join Date
    Sep 2007
    Location
    Tain - Easter Ross
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Windscreen Washers

    Anyones frozen yet? Been minus double figures for the better part of 2 weeks now and mine still work fine and have done the whole time.

    Insignia jets with straight screenwash concentrate, either Holts or Motoquip stuff.

    Got the same in the work Crafter and its been frozen the whole time but am putting that down to poor design.

  2. #2
    Regular Member macdad's Avatar
    Join Date
    Dec 2007
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have heated jets mate,what a waste of time they are,well they are arnt they,for the simple reason thay don't shockin work do they.

  3. #3
    Regular Member RobW's Avatar
    Join Date
    Sep 2007
    Location
    Tain - Easter Ross
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Used to have them and swapped for the Insignia jets

  4. #4
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    I found mine (Insignia jets) working fine up and down the M6/M1 last week..... the only problem came when some snow managed to settle in the larger void in front of the driver's side jet and rapidly became green snow while the passenger side continued to work fine.

  5. #5
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    37 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    Was up to my parents on Wednesday, frozen jets even with 100% straight concentrate screen wash, I guess the wind chill was down to -20 on the way up the M90. Think i'll pick up heated jets soon.

  6. #6
    Regular Member Jezzy's Avatar
    Join Date
    May 2009
    Location
    S.E
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    There's a whole thread on this subject already:

    http://www.vectra-c.com/forum/showthread.php?t=123507

  7. #7
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine haven't worked for the past 3 days, i eventually removed both jets and the piping but the water is just slowly trickling out.I even emptied the water bottle and refilled it with hot water but still no luck

    Looks like i'll have to replace the motor and hopefully that will fix it

  8. #8
    Regular Member
    Join Date
    Aug 2010
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks to this site and the top advice which was neat screenwash not mixed rubbish it now works at -18 and no problems.

    It really is that simple.

  9. #9
    Regular Member Dazzy2006's Avatar
    Join Date
    Dec 2009
    Location
    Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Bigtee View Post
    Thanks to this site and the top advice which was neat screenwash not mixed rubbish it now works at -18 and no problems.

    It really is that simple.
    Mine has neat screenwash but still not working thats why i suspect the pump has had it

  10. #10
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    Quote Originally Posted by Dazzy2006 View Post
    Mine has neat screenwash but still not working thats why i suspect the pump has had it
    If you're still getting something out of them then there's a good bet it's just the little rubber filter (part of the rubber grommet the pump mounts into) that is gunked up. Pull the motor and grommet out and clean through both with warm water before you write off the motor.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Windscreen Washers
    By Bloicy in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 18th April 2012, 22:42
  2. windscreen washers
    By bigsteve2255 in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 7th January 2011, 23:08
  3. Windscreen Washers.......
    By david.aka.judas in forum Bodywork & Interior
    Replies: 7
    Last Post: 16th December 2008, 23:25
  4. windscreen washers
    By woody in shetland in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 2nd May 2008, 19:04
  5. Windscreen washers
    By T4M in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 4th September 2007, 23:33

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •