User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: preface indicator stalk

  1. #1
    Regular Member
    Join Date
    Aug 2010
    Location
    herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Arrow preface indicator stalk

    how do you remove the indicator stalk on these vectras please

  2. #2
    Ex Vec-C Admin Ian-Highlander's Avatar
    Join Date
    Jun 2008
    Location
    Ely, Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Tourer

    Trim : Elite

    Engine : 2.0 CDTI (160ps)

    Year : 2010

    Default

    They actually just pull out, but to make it easier, stick a small piece of wire down one side of it (you'll see a small notch) this releases the clip and makes it easier to do.

    Edit: more info in this old thread. http://www.vectra-c.com/forum/showthread.php?t=100146
    Last edited by Ian-Highlander; 23rd December 2010 at 12:04.
    "Doing a good job here is like wetting your pants in a dark suit, you get a warm feeling but nobody else notices"
    Maptun Tuned 2.0T Estate - click HERE for mods list.
    Brentwood 2012: Winner, Saturday Show. Hull 2012: Winner, Best Estate. Hull 2013: Winner, Best Estate & Runner Up, Best I.C.E

    Now Gone, bring on the Insignia (now "Teapot" Tuned)...

  3. #3
    Regular Member BigWilko's Avatar
    Join Date
    Jan 2010
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 3.0 CDTI

    Year : 2005

    Default

    unfold a paperclip and thread it down the groove on the underside of the stalk. That'll save you rounding off the locators that lock it in

  4. #4
    Regular Member kman247's Avatar
    Join Date
    Nov 2008
    Location
    milton keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    personally I find a small allen key perfect

  5. #5
    Regular Member
    Join Date
    Nov 2007
    Location
    North Wingfield, Chesterfield, Derbyshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by leesri View Post
    how do you remove the indicator stalk on these vectras please
    Does the same technique apply to the multifunction wiper stalk ????

    I'm having trouble with this...lost control on some functions which I've put down to the freezing temperatures upsetting control of the wipers - which have been the subject of various threads/posts on here & which I've also contributed to.

    This time the 'wiper problems' did not correct themselves after the engine bay 'warmed-up' as what seemed to be the case on previous occasions with mine & other people.

    I'm hoping it's not a problem with the multifunction steering column ECU
    .

    Any comments would be appreciated...

    Cheers

    PS the car is a 55 reg Facelift Club Spec Vectra Hatch....

  6. #6
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Tony W View Post
    I'm having trouble with this...lost control on some functions which I've put down to the freezing temperatures upsetting control of the wipers - which have been the subject of various threads/posts on here & which I've also contributed to.

    This time the 'wiper problems' did not correct themselves after the engine bay 'warmed-up' as what seemed to be the case on previous occasions with mine & other people.

    I'm hoping it's not a problem with the multifunction steering column ECU
    .
    Quite a few posts regarding wiper issues at the moment.

    I thought such issues with wipers when really cold was to do with the microswitch inside the wiper motor/gearbox getting stuck or the earthing of the unit to the car failing. These things cause problems like wipers don't work or do what you tell them to, or they 'forget' where the park position is.

    My car does this, but fortunately very rarely and not at all yet in this current freezing weather.

    Maybe it just hasn't warmed up enough yet to thaw out properly?

  7. #7
    Regular Member
    Join Date
    Nov 2007
    Location
    North Wingfield, Chesterfield, Derbyshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeh James...it's a well known Vectra C 'quirk' on here mate...& became apparent in my case a couple of years ago or so ago when the winter temperatures dropped to freezing & below...
    Unfortunately, the multifunction indicator & washers switches are all part of the steering column ECU and any problem with a component that's part of it cannot be replaced individually...it's a new ECU as I understand...Cheers

  8. #8
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Tony W View Post
    Yeh James...it's a well known Vectra C 'quirk' on here mate...& became apparent in my case a couple of years ago or so ago when the winter temperatures dropped to freezing & below...
    Unfortunately, the multifunction indicator & washers switches are all part of the steering column ECU and any problem with a component that's part of it cannot be replaced individually...it's a new ECU as I understand...Cheers
    I'm not saying it's not the CIM but I would have thought that - seeing as it controls or plays a part in many functions - that you would see other issues if the CIM was playing up due to the cold, not just the wipers. People have posted about the wiper motor microswitch/earth and relay causing wiper problems in very cold weather.

    Also, the wiper motor and relay are under the bonnet whereas the CIM is in the car so surely they'd be even more affected by the cold (and freezing water) that the CIM which is insulated a bit inside the steering column inside the car.

    As the CIM is expensive, I'd - as ever - rule out the cheap/easy things first by checking the wiper motor microswitch, earthing, and the wiper relay as other people have posted about previously (with guides and pictures in some cases) before getting a new CIM and running the risk of it not fixing the problem.

  9. #9
    Regular Member
    Join Date
    Nov 2007
    Location
    North Wingfield, Chesterfield, Derbyshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by James24 View Post
    I'm not saying it's not the CIM but I would have thought that - seeing as it controls or plays a part in many functions - that you would see other issues if the CIM was playing up due to the cold, not just the wipers. People have posted about the wiper motor microswitch/earth and relay causing wiper problems in very cold weather.

    Also, the wiper motor and relay are under the bonnet whereas the CIM is in the car so surely they'd be even more affected by the cold (and freezing water) that the CIM which is insulated a bit inside the steering column inside the car.

    As the CIM is expensive, I'd - as ever - rule out the cheap/easy things first by checking the wiper motor microswitch, earthing, and the wiper relay as other people have posted about previously (with guides and pictures in some cases) before getting a new CIM and running the risk of it not fixing the problem.
    I entirely agree with your comments James after reading the various threads/posts on here re - wiper operation issues..i.e. look for the simple solutions first...which I plan to do when the weather gets a bit warmer....assuming they don't return to normal operation as they've done in the past....

    I was hoping that if the wiper/washer 'switch' turned out to be faulty & not the wiper motor. rods etc, it would just be a case of changing that as I'd changed the indicator switch & stalk on the Mark 3 Cavalier we had before the Vectra...BUT on reading the Haynes Manual it doesn't have separate switches..It's a ECU module change as mebntioned...

    My post below from the thread 'Mad Wipers this morning' gives the current position re- wiper/washer operation on the car....if you've not read it

    http://www.vectra-c.com/forum/showpo...8&postcount=17

    Cheers

  10. #10
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I haven't heard of wiper stalks failing - only indicator ones. I suppose that's because the indicator stalk is used far more often and gets worn out/dirty inside far faster than the one for the wipers.

    It's worth checking the wiper stalk - it's quick and free. Maybe clean the contacts and see if there any visible issues with it?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Indicator Stalk query
    By phils in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 13th October 2010, 18:01
  2. New indicator stalk
    By j1 wyx in forum Parts for sale
    Replies: 0
    Last Post: 13th June 2010, 10:25
  3. Indicator stalk
    By old cruiser in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 2nd October 2009, 13:58
  4. Indicator stalk boot
    By shan in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 25th March 2008, 22:12

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •